openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kay Schenk <kay.sch...@gmail.com>
Subject Re: Broken desktop-integration in 4.1.1
Date Mon, 25 Aug 2014 15:09:14 GMT
On Mon, Aug 25, 2014 at 2:28 AM, Michal Hriň <hrin@apache.org> wrote:

> Hi,
>
> I'm trying release 4.1.1 on my system Ubuntu with KDE 4.13.3 and
> desktop-integration is broken.
>
> Symlinks to soffice works but, when I tried to run program by clicking to
> icon in menu nothing happens or I got a "Warning" which says
>
> "Program will be executed: openoffice4 %U" by clicking on "Run" button
> nothings happens.
>

Which desktop-integration did you install?

The freedesktop  integration works for me with KDE 4.10 on opensuse 12.3.


> Notice / question:
>
> Have I create issue? (in bugzilla is only 4.1 and 4.2.0-dev version)
>
> As I'm playing with building of program, and I want to refresh my
> programming, can someone point me to some reading about desktop-integration
> and to the source where is the code of it ?
>
> Why builds are provided without KDE integration ? When I tried to build
> program --with-kde I didn't know which libraries build script expected.
> Can someone point me which libraries and of what version are expected for
> successful build with kde-integration?
>

In configure.in in the source tree, you will find 2 parameters dealing
withe kde --
--enable-kde
--enable-kde4

I haven't followed the complete configuration to determine where kde4 is
used.

Also in configure.in, you will get to a section with starting comments

"Check whether the Qt and KDE libraries are available."

for more information on libraries needed.

Since both Gnome and KDE now follow the freedesktop specification, that
desktop integration seems to work well for most users.


> Regards,
> Michal Hriň
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>


-- 
-------------------------------------------------------------------------------------------------
MzK

"For evil to flourish, it only requires good men to do nothing."
                                                  -- Simon Wiesenthal

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message