openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Pescetti <pesce...@apache.org>
Subject Re: Problem building AOO
Date Thu, 04 Sep 2014 16:10:14 GMT
On 04/09/2014 zimuzo ezeozue wrote:
> I was using* g++ 4.6*, I updated to *g++ (Ubuntu 4.8.1-2ubuntu1~12.04)
> 4.8.1, *but I'm still experiencing the same problem:

I recommend sticking with the default compiler you have. OpenOffice 
compiles cleanly on Ubuntu 12.04, even our Linux buildbots at 
http://ci.apache.org/projects/openoffice/index.html probably run on 
Ubuntu 12.04. gcc 4.8 should be fine anyway, and build should also work 
on the newer Ubuntu 14.04 (with gcc 4.8) since Amali fixed it.

> 1 module(s):
> toolkit
> need(s) to be rebuilt

Let's see if it is a permanent error or just an issue related to 
abruptly stopping the build, or out of disk space (I've seen similar 
errors from time to time).

For a very quick and brutal test, try removing (or renaming) this 
directory: solver/420/unxlngx6.pro/workdir/CxxObject/toolkit
and then go again through the configure, bootstrap, source, "build 
--all" steps.

If you still see the problem, please post the exact syntax of your 
./configure command: I and others have Ubuntu 12.04 virtual machines and 
can see if problem is reproducible.

Regards,
   Andrea.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message