openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From jupiter <jupiter....@gmail.com>
Subject Re: Build source from svn repository errors
Date Sat, 15 Nov 2014 00:34:42 GMT
On Sat, Nov 15, 2014 at 11:06 AM, Kay Schenk <kay.schenk@gmail.com> wrote:

>
>
> On 11/14/2014 03:32 PM, jupiter wrote:
> > Thanks Alexandro, yes I did follow the build guides.
> >
> > Anyway, I had a quick look at the code packimages.pl and found following
> > invalid path passed to $zip->addFile, the file
> > /Build2/aoo/main/default_images/res/helpimg|/area1.png was fine, but
> > following path was wrong. My gut felling is at least the packimages.pl
> > should check the path before passing to the $zip->addFile. I added a
> check
> > statement next unless (-e $path); which completed the build process, but
> > did not fix the issue why an invalid path was generated.
> >
> >
> /Build2/aoo/main/default_images/res/|-dir=/Build2/aoo/main/default_images/res/helpimg|/area1.png'
> >
> > Thank you.
> >
> > - hce
>
> You could try adding --
>
> VERBOSE_PACKIMG="TRUE"
>
> to your environment script (the one sourced before building), also
> include this in the export set at the bottom of that script.
>
> Then try a rebuild (clean build) -- see Build Cleanup
> (
> https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO#Build_Cleanup
> )
>
> When you review output for packimages, you should then see output
> messages of the images that are to be archived along with their paths.
>
> This would help us determine what paths are checked and why this happened.
>
> To my knowledge, I don't think this has been reported before.
>
> Will do it.

Sorry for a dumb question, it is my first time to build the open office. I
guess the binary executable file is openoffice.org, but I could not find
it..

$ ls aoo/main/instsetoo_native/
unxlngx6.pro/OpenOffice/installed/install/en-US/openoffice.org
basis3.5  ure

- hce

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message