openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From 郄宁 <qienin...@163.com>
Subject compile error
Date Thu, 08 Jan 2015 08:10:43 GMT
Hi~
In the win 7 system compile  OO source code error as shown below:


zhhh@zhhh-PC ~/aoo-4.1.1
$ cd main


zhhh@zhhh-PC ~/aoo-4.1.1/main
$ ./configure --disable-build-mozilla  --with-mozilla-build="/cygdrive/d/Program Files/mozilla-build"
\  --with-cl-home="/cygdrive/d/Program Files (x86)/Microsoft Visual Studio 9.0/VC" \  --with-mspdb-path="/cygdrive/d/Program
Files (x86)/Microsoft Visual Studio 9.0/Common7/IDE" \  --with-frame-home="/cygdrive/c/Program
Files/Microsoft SDKs/Windows/v6.1" \  --with-psdk-home="/cygdrive/c/Program Files/Microsoft
SDKs/Windows/v6.1" \  --with-midl-path="/cygdrive/c/Program Files/Microsoft SDKs/Windows/v6.1/Bin"
\  --with-asm-home="/cygdrive/d/Program Files (x86)/Microsoft Visual Studio 9.0/VC/Bin" \
 --with-csc-path="/cygdrive/c/WINDOWS/Microsoft.NET/Framework/v3.5" \  --with-jdk-home="/cygdrive/c/Program
Files (x86)/Java/jdk1.7.0_71" \  --with-directx-home="/cygdrive/d/OOo/DirectXSDK" \  --with-ant-home="/cygdrive/d/ant/apache-ant-1.9.3"
\
>
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: you should use --build, --host, --target
configure: WARNING: invalid host type:
configure: WARNING: unrecognized options: --disable-build-mozilla
checking whether configure is up-to-date... yes
********************************************************************
*                                                                  *
*   Apache OpenOffice build configuration.                         *
*                                                                  *
*   The configure process checks your platform to see whether      *
*   you can build Apache OpenOffice on it.                         *
*   This process checks all pre-requisites and generates a file    *
*   containing the necessary environment variables.                *
*   Source this file after configure has ended successfully.       *
*                                                                  *
*   Warnings that are generated during the configure process       *
*   must be taken into account since it can be a reason for        *
*   an unsuccessful build of Apache OpenOffice.                    *
*                                                                  *
********************************************************************


********************************************************************
*                                                                  *
*   Checking the platform pre-requisites.                          *
*                                                                  *
********************************************************************


checking for grep that handles long lines and -e... /usr/bin/grep
checking for egrep... /usr/bin/grep -E
checking for gawk... gawk
checking for gawk... /usr/bin/gawk
checking for sed... /usr/bin/sed
checking for solenv environment... default
checking for custom pack.lst... no
checking build system type... config.sub: missing argument
Try `config.sub --help' for more information.
configure: error: /bin/sh ./config.sub   failed


zhhh@zhhh-PC ~/aoo-4.1.1/main
$ config.sub --help
-bash: config.sub: command not found

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message