openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dennis Roczek <dennisroc...@gmail.com>
Subject Re: [DISCUSS] Java 8 and AOO
Date Wed, 18 Mar 2015 23:25:47 GMT
Err,

Am 19.03.2015 um 00:22 schrieb Dennis Roczek:
> Hi,
>
> Am 18.03.2015 um 23:46 schrieb Kay Schenk:
>>
>>
>> On 03/18/2015 09:29 AM, Dennis E. Hamilton wrote:
>>> Larry, that's great.  I saw that in a screen shot that showed both of
>>> them installed.
>>>
>>> Please add that link to Bugzilla issue 126130.  If you don't have an
>>> account there, let me know and I will do it.
>>
>> OK, I see Larry has done this.
>>
>> I took a cursory look at Ariels's Comment 7 also.
>> It would help if we knew what particular functions of AOO failed without
>> the use of Java 6.
>>
>> Many months ago, I tried to get, through additional java flags, what
>> problems any  of our java code might be causing for java 7 specifically.
>> Some methods we are using are deprecated, but I didn't interpret these
>> as show stoppers. However, I will upgrade to Java 8, and run through
>> this scenario again to see what comes out.
>>
>> Thanks for all the comments.
> Well I follow the LibreOffice development intensively. I can't find the
> correct bug number right now,  but
> https://bugs.documentfoundation.org/show_bug.cgi?id=44679 seems related:
> Apple and Oracle (depending on JRE and OS version) change at OS X 10.7 /
> 10.8 the standard install path and the detection mode. LibreOffice tries
> now (if i remember correctly) to detect first the old JRE6 path and
> afterwards the jre7 path - doesn't matter was "java --version" says.
>
> All in all, the mess happens by the Apple to Oracle switch somewhen
> Oracle overtook the Java development and apple didn't want to maintain
> JRE any longer (similar to flash, but that's another story)
>
> So try to detect the correct Java version / path esp. if it is a clean
> install and not upgraded from (e.g.) 10.5 to 10.10....
>
> Regards,
> Dennis Roczek


I believe I found the bug numbers: it's about 64-bit:
https://bugs.documentfoundation.org/show_bug.cgi?id=66014
and
https://bugs.documentfoundation.org/show_bug.cgi?id=70846

just FYI... ;-)

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message