openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dennis E. Hamilton" <>
Subject RE: Simple code practice to get started
Date Sun, 09 Aug 2015 16:54:30 GMT
Building AOO does not put its results where an operating version of AOO has been installed
on Windows.  

It sounds like you have not built the entire package.  Or you built it but did not run the
installer that you built.  Running the installer will replace an existing version.  It would
be good to not do that on a PC that you are using for production purposes [;<).

 - Dennis

PS: If you have a new soffice.bin, you could rename the one in "Program Files (x86)\OpenOffice
4\program\" and then copy your new one there.  Previous warnings apply.  Good luck. 

-----Original Message-----
From: Jason Marshall [] 
Sent: Sunday, August 9, 2015 09:03
Subject: Simple code practice to get started

Hi everyone
I have successfully built OpenOffice 4.1.1 on a 32 bit Windows 7 platform.  I have installed
this with windows integration and it runs with no problem.  I have then tried to make a couple
of changes to the code as defined by the following hacks on the OpenOffice wiki (addition
of extra 'OK' button in about dialog box and reversal of menus):
Within the directory of the relevant module changed (e. g. /cygdrive/c/aoo44/main/vcl), I
then call build and the build appears to complete with no issue.  However, when I start OpenOffice
from the icon on the Windows taskbar, the changes do not appear to have carried through, such
that none of the coded changes are visible.
I have taken care to ensure that OpenOffice is closed and then re-opened following the build,
but to no avail.  I am guessing that for some reason I am not starting OpenOffice correctly,
such that it is still running on code which does not contain the changes that I have made.
 Alternatively, perhaps the build has not actually worked correctly without me being aware
of this.  I am aware that the hacking guide stipulates that OpenOffice should be started from
the Cygwin command line.  I have tried this, but the bash states the following:
Jason and Emma@JasonandEmma-PC /cygdrive/c/aoo411/main/solver/411/
$ . soffice.bin
-bash: .: soffice.bin: cannot execute binary file
I suspect that my mistake is really rather elementary and perhaps indicates my own lack of
knowledge about how things work.  Accordingly, any advice would be much appreciated.
Thank you.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message