openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jason Marshall <>
Subject RE: Simple code practice to get started
Date Sun, 09 Aug 2015 18:20:15 GMT
Dear Dennis
Thank you for looking at this problem.  Please forgive the length of the following e-mail;
I suspect that when I have mastered the environmental set-up of OpenOffice, then likely any
subsequewnt questions I can answer myself and will be far shorter.
>From what you are saying, I think that although I may have re-built the relevant modules
where I changed the code, this of course did not carry over to the already-installed software
on Windows which I installed immediately following the first complete build.
I have located using 'find' three 'soffice.bin' files in the following directories of the
code source:

Only the 'soffice.bin' in the second path above shows a file date of today, which would indicate
that it has been changed by the re-build of changed modules today.  Would it therefore be
reasonable of me to infer that this is the correct version of the file out of the three that
now presumably encapsulates the code changes following the re-build?
Accordingly, I copied this version of 'soffice.bin' into the Windows installation location
of OpenOffice and replaced the original version of this file.  While OpenOffice runs as usual,
again, I do not see any of the obvious changes that the hacks were intended to achieve.  Accordingly,
I would infer from this that the re-builds of the two modules 'cui' and 'vcl' have not worked.
 In your view, would this be the likely scenario?  Also, both builds appeared to run until
completion with no obvious errors, so if this was the case, then I am unclear as to why the
changes are not now apparent when OpenOffice is run.
When tinkering with code, I am imagining that it is not necessary to re-install OpenOffice
every time a module is re-built and note that you advised me to simply copy the changed 'soffice.bin'
into the install directory and run that within the original Windows installation.  Could you
confirm if this is the typical way that one does test code changes, or is there another way
to quickly run OpenOffice in order to see changes that have been made.
In terms of any full re-installation, I now note that since the 'cui' and 'vcl' module re-build
today that the following directory appears to have disappeared:
However, the following directly has since appeared, which is empty and seems to have replaced
This appears to indicate that the installation files have now gone following re-build today.
 Would I need to rebuild everything in order to get the install files back?
Thank you again for your help.
Best regards

> From:
> To:
> Subject: RE: Simple code practice to get started
> Date: Sun, 9 Aug 2015 09:54:30 -0700
> Building AOO does not put its results where an operating version of AOO has been installed
on Windows.  
> It sounds like you have not built the entire package.  Or you built it but did not run
the installer that you built.  Running the installer will replace an existing version.  It
would be good to not do that on a PC that you are using for production purposes [;<).
>  - Dennis
> PS: If you have a new soffice.bin, you could rename the one in "Program Files (x86)\OpenOffice
4\program\" and then copy your new one there.  Previous warnings apply.  Good luck. 
> -----Original Message-----
> From: Jason Marshall [] 
> Sent: Sunday, August 9, 2015 09:03
> To:
> Subject: Simple code practice to get started
> Hi everyone
> I have successfully built OpenOffice 4.1.1 on a 32 bit Windows 7 platform.  I have installed
this with windows integration and it runs with no problem.  I have then tried to make a couple
of changes to the code as defined by the following hacks on the OpenOffice wiki (addition
of extra 'OK' button in about dialog box and reversal of menus):
> Within the directory of the relevant module changed (e. g. /cygdrive/c/aoo44/main/vcl),
I then call build and the build appears to complete with no issue.  However, when I start
OpenOffice from the icon on the Windows taskbar, the changes do not appear to have carried
through, such that none of the coded changes are visible.
> I have taken care to ensure that OpenOffice is closed and then re-opened following the
build, but to no avail.  I am guessing that for some reason I am not starting OpenOffice correctly,
such that it is still running on code which does not contain the changes that I have made.
 Alternatively, perhaps the build has not actually worked correctly without me being aware
of this.  I am aware that the hacking guide stipulates that OpenOffice should be started from
the Cygwin command line.  I have tried this, but the bash states the following:
> Jason and Emma@JasonandEmma-PC /cygdrive/c/aoo411/main/solver/411/
> $ . soffice.bin
> -bash: .: soffice.bin: cannot execute binary file
> I suspect that my mistake is really rather elementary and perhaps indicates my own lack
of knowledge about how things work.  Accordingly, any advice would be much appreciated.
> Thank you.
> Jason
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message