openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kay Schenk <kay.sch...@gmail.com>
Subject Re: building problems with recent changes -- /sal/qa/osl module
Date Mon, 12 Oct 2015 16:20:46 GMT


On 10/11/2015 04:28 PM, Don Lewis wrote:
> On 10 Oct, Damjan Jovanovic wrote:
>> The FreeBSD buildbot and 1 Linux buildbot have also been getting this, yet
>> 2 of us now couldn't reproduce it.
>>
>> Please provide:
>> * SVN revision
>> * full configure options
>> * the compile log from earlier on (containing the command run that produces
>> that error)
>>
>> Thank you
>> Damjan
>>
>>
>> On Fri, Oct 9, 2015 at 11:07 PM, Kay Schenk <kay.schenk@gmail.com> wrote:
>>
>>> Hello --
>>>
>>> Currently, I am having problems building due to some recent changes in
>>> sal/qa/osl/
>>>
>>>
>>> sal/qa/osl/thread/test_thread.cxx seems to be successfully compiled but on
>>> making qa_osl_thread, I am getting the following errors --
>>>
>>> /usr/bin/ld: cannot find -lsalcpprt
>>> collect2: ld returned 1 exit status
>>> dmake:  Error code 1, while making '../../../
>>> unxlngi6.pro/bin/qa_osl_thread'
>>>
>>> Any help appreciated.
> 
> 
> The FreeBSD buildbot seems to be happy now.
> 
> I wonder if this an out of order build problem.  In my last build I
> see that the sal_ut_osl_pipe, sal_ut_osl_condition, and sal_ut_test
> tests are all successfully run before the qa_osl_thread test, and all of
> them use -lsalcpprt.  If I'm intepreting man/sal/prj/build.lst
> correctly, the first three of those are all specifying sa_cpprt.u as a
> dependency:
> 
> sa sal\qa\osl\pipe nmake - all sa_qa_osl_pipe sa_util  sa_cpprt.u NULL
> sa sal\qa\osl\condition nmake - all sa_qa_osl_condition sa_util sa_cpprt.u NULL
> sa sal\qa\sal nmake - all sa_qa_sal sa_util  sa_cpprt.u NULL
> 
> whereas qa_osl_thread does not:
> sa sal\qa\osl\thread nmake - all sa_qa_osl_thread sa_util NULL
> 
> I wonder if the failing builds are trying to run the thread test before
> the libsalcpprt has been built?

Hi Don --

I spent some time looking into this yesterday. I think your analysis
could be correct. I will investigate further today when I get a
chance. I'm not sure why it's just seems to be affecting MY 32-bit
Linux build however. :(


-- 
--------------------------------------------
MzK

“The journey of a thousand miles begins
 with a single step.”
                          --Lao Tzu



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message