openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@apache.org>
Subject Re: [QUESTION] Dependency on OpenSSL
Date Wed, 08 Jun 2016 21:59:03 GMT
On  8 Jun, Dennis E. Hamilton wrote:
> I recall discussions of OpenSSL and updating our dependency on it to a better/patched
version.
> 
> What I don't know is whether the binaries that are built and distributed directly by
the project incorporate OpenSSL in any manner?
> 
> Can anyone clear that up?
> 
>  1. Do our built binaries depend on and distribute OpenSSL in some manner?

Yes.

>  2. Is this for all platforms or only some of them?

It appears that all do.  That makes sense since Windows doesn't have it,
and on Linux you don't know what version will be present on the host
where the binaries are installed (and the OpenSSL ABI changes between
major release versions).

The FreeBSD port uses the system OpenSSL.  It passes
--with-system-openssl to configure.  This works for FreeBSD because
different binary packages are generated for each FreeBSD major version,
and within a FreeBSD major version the OpenSSL ABI does not change.

The lastest OpenSSL should just drop in.  I haven't seen any problems
building on FreeBSD with the latest and greatest.



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message