openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kay Schenk <kay.sch...@gmail.com>
Subject Re: problem downloading dependencies and building on Fedora x86-64
Date Thu, 30 Jun 2016 15:36:47 GMT
On Wed, Jun 29, 2016 at 5:38 PM, Carl Marcum <cmarcum@apache.org> wrote:

> Hi all,
>
> I'm attempting a build of 4.1.2 on Fedora 20 x64 from downloaded source to
> closely match the same configure options as the release except for adding:
> --with-package-format="installed"
>
>
> LANGS="ast bg ca ca-XR ca-XV cs da de el en-GB en-US es eu fi fr gd gl he
> hi hu it ja kid km ko lt nb nl pl pt pt-BR ru sk sl sr sv ta th tr vi zh-CN
> zh-TW"
>
> ./configure   \
>              --with-build-version="$(date +"%Y-%m-%d %H:%M") - `uname
> -sm`" \
>              --enable-verbose \
>              --with-system-stdlibs \
>              --enable-crashdump=yes \
>              --enable-category-b \
>              --enable-wiki-publisher \
>              --enable-bundled-dictionaries \
>              --enable-opengl  \
>              --enable-dbus  \
>              --enable-gstreamer \
>              --with-package-format="rpm deb" \
>              --with-lang="${LANGS}" \
> --with-dmake-url=
> http://dmake.apache-extras.org.codespot.com/files/dmake-4.12.tar.bz2 \
> --with-epm-url=http://www.msweet.org/files/project2/epm-3.7-source.tar.gz
> \
>                 --with-package-format="installed"
>
> during ./bootstrap I'm getting a lot of download errors like:
>
> download from
> http://sourceforge.net/projects/hsqldb/files/hsqldb/hsqldb_1_8_0/hsqldb_1_8_0_10.zip/download
> failed
>     download failed
>
>
>
> and my relevant output from "build --all"
>
>
>
> =============
> Building module hsqldb
> =============
>
> Entering /home/carl/dev/aoo/aoo-4.1.2/main/hsqldb
>
> mkout -- version: 1.8
> dmake:  Error: -- `./
> unxlngx6.pro/misc/17410483b5b5f267aa18b7e00b65e6e0-hsqldb_1_8_0.unpack'
> not found, and can't be made
>
> 1 module(s):
>     hsqldb
> need(s) to be rebuilt
>
> Reason(s):
>
> ERROR: error 65280 occurred while making
> /home/carl/dev/aoo/aoo-4.1.2/main/hsqldb
>
> When you have fixed the errors in that module you can resume the build by
> running:
>
>     build --all:hsqldb
>
> Any help would be greatly appreciated.
>
> Thanks,
> Carl
>

​AHA! Since 4.1.2, some of the download sites, especially Sourceforge, have
swithced to https, instead of http. Please check your Perl installation and
see if you have LWP::Protocol installed which supplies the https access for
LWP::UserAgent.

We need to add this to our build information as well.

ps.  I don't know what Java you're using, but I couldn't build 4.1.2 with
Java 1.8, and had to use Java 1.7 instead.
​


-- 
----------------------------------------------------------------------
MzK

"Time spent with cats is never wasted."
                                -- Sigmund Freud

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message