openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@apache.org>
Subject Re: Download Junit and Hamcrest in ./bootstrap?
Date Thu, 11 Aug 2016 16:53:30 GMT
On 11 Aug, Kay Schenk@apache.org wrote:
> 
> On 08/11/2016 01:42 AM, Damjan Jovanovic wrote:
>> Hi
>> 
>> If you've been checking the buildbots you'll see that all who don't use
>> --without-junit are currently broken in ./configure due to junit being too
>> old. This is unlikely to change, as the buildslaves are running Ubuntu
>> 10.04 which doesn't have newer versions of Junit available in apt.
>> 
>> This is part of a bigger problem, which is that Junit's dependencies
>> changed multiple times in the 4.x releases, which is why I changed
>> configure.ac to need at least 4.11 (the maximum being 4.12).
>> 
>> Instead of needing a correct system Junit version to run tests during the
>> build, and having to worry about having correct system versions of Hamcrest
>> on the classpath, should we not rather treat them like external
>> dependencies and download specific versions during ./bootstrap? It's under
>> 300 kB for both, and the bvt/fvt/pvt tests already download their own copy.
>> 
>> Damjan
>> 
> 
> This would be OK with me. What version of the jre does Junit 4.11
> require? I can't find information about this on the junit site
> --http://junit.org/junit4/
> 
> Right now, we're still spec'd at jdk 1.6 for everything except Windows,
> but IMO we should advance to 1.7 .

That sounds good to me as well, but are there any issues with installing
a newer jdk on older Linux distributions that we still support?


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message