openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@apache.org>
Subject Re: upgrading bundled openssl
Date Fri, 19 Aug 2016 18:34:16 GMT
On 15 Aug, Marcus wrote:
> Am 08/15/2016 10:16 PM, schrieb Don Lewis:
>> I started working on upgrading the bundled version of openssl to 1.0.2h.
>> So far I've discovered that building in on Windows requires nasm.  That
>> will need to be documented in the build requirements / procedures.  I
>> think I need to add a check to configure to look for it and bail out if
>> nasm isn't installed, but I haven't gotten that far yet.  The Windows
>> buildbot will need to have nasm installed.
> 
> puh, so many dependencis and it's still increasing. ;-)
> 
> Thanks for working this out.

I figured out how to make nasm an optional dependency, so the openssl
update commit I just made won't immediately break our Windows buildbot.

The upcoming serf upgrade also has a new dependency issue.  It has
changed to using scons as its build system, which has its own
dependencies, python and m4.  I haven't yet decided what to do about
that.



---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message