openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@apache.org>
Subject Re: [DISCUSS] Release 4.2: General Topics
Date Thu, 25 Aug 2016 22:57:28 GMT
On 25 Aug, Andrea Pescetti wrote:

>>> 2. Update Java requirement from Java 1.5 to *at least* Java 1.7
>>> I am rather adamant that we change our building requirement to Java 1.7
>>> for all platforms. I will be changing that in our Building Guide today.
>>
>> Is there a real reason for it? I see this like saying (this is just an
>> example, not to be taken literally) "we drop support for Windows XP
>> since it's old and unsupported". In short: if we need work to drop Java
>> 1.5 then we have clear advantages in raising our requirement to 1.7,
>> otherwise we can simply drop the requirement saying "we won't explicitly
>> test compatibility with Java < 1.7"; but in that case we must provide
>> ways to obtain a compatible JRE for all the 4 supported platforms.

In the experiments that I've done, it seems like if you build with a
certain Java version, the resulting executables won't work with an older
Java version on the machine where the installation is done.


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message