openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrea Pescetti <pesce...@apache.org>
Subject Re: 4.1.3 building
Date Wed, 21 Sep 2016 22:25:19 GMT
Patricia Shanahan wrote:
> 1. My current policy for release blocker is to grant it immediately if
> it seems obvious to me that a fix is needed to build 4.1.3. I will also
> do so based on prior security@ discussion. Otherwise, I'll ask for input
> on dev@ before deciding.

OK. 4.1.4 is a good fallback solution for important but not critical 
bugs anyway.

> 2. I would like to get a list of environments in which 4.1.3 has been
> successfully built. I'll announce time to build a release candidate when
> it builds in the required environments.

I've built AOO413 on Linux-64 with the following details:
- CentOS 5 VM as described in 
https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#CentOS_5
- Source revision r1761818
- Real source revision r1761381 (both are obtained using "svn info"; the 
latter is the one that matters, as the former increases for any commit 
in any ASF project)
- Build scripts as per 
http://svn.apache.org/viewvc/openoffice/devtools/build-scripts/4.1.3/unxlngix6/

Sample builds (English, German, Italian) from a few hours ago -but not 
from my latest build- are at 
http://home.apache.org/~pescetti/openoffice-4.1.3-dev-r1761683/

There are a few differences in the configure options, namely:

1) Build Version is a bit richer in 
https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step#Configure 
but I went for the more compact one from the 4.1.2 scripts

2) Language list is much longer in the 4.1.2 scripts and I maintained 
that one - even though I usually build with fewer languages

3) Package format does not have "installed" in the 4.1.2 scripts, which 
looks OK (we only ship RPM+DEB)

4) We were using ant 1.7.1 (from the repositories?) for 4.1.2 builds, 
see 
http://svn.apache.org/viewvc/openoffice/devtools/build-scripts/4.1.2/unxlngix6/config.log?revision=1736814&view=markup#l1134

; we download and use 1.9.7 now; I haven't checked this properly yet, 
but we had a recent discussion with Kay saying that configure (which 
checks for ant >= 1.7.0) was wrong.

5) We are now explicitly passing --without-stlport which looks good 
since (if I recall correctly) this was the default anyway.

6) We are now passing --without-junit ; I'm still not completely clear 
if this makes any difference in our case.

Regards,
   Andrea.

---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message