openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus <marcus.m...@wtnet.de>
Subject Re: 4.1.3 building
Date Sun, 25 Sep 2016 18:20:48 GMT
Am 09/25/2016 12:03 AM, schrieb Marcus:
> Am 09/24/2016 03:51 PM, schrieb Marcus:
>> Am 09/23/2016 10:18 PM, schrieb Marcus:
>>> Am 09/23/2016 10:12 PM, schrieb Patricia Shanahan:
>>>> On 9/23/2016 1:00 PM, Marcus wrote:
>>>>> Am 09/23/2016 09:26 PM, schrieb Ariel Constenla-Haile:
>>>>>> On Thu, Sep 22, 2016 at 12:25:19AM +0200, Andrea Pescetti wrote:
>>>>>>> - Source revision r1761818
>>>>>>
>>>>>> Isn't this time to agree that this revision will be the one we
>>>>>> release?
>>>>>> Haven't seen any call from the RM, but it might be time to start
>>>>>> building it ;)
>>>>>>
>>>>>> I'll start doing so on Windows, as Jim and Andrea seem to cover the
>>>>>> other platforms.
>>>>>
>>>>> @Patricia:
>>>>> Maybe you can tell us what your further plan is. Do you have any other
>>>>> fixes in mind?
>>>
>>> 2 persons with the same thought in the same minute. ;-)
>>>
>>>> No more fixes in mind, and I believe it has been built in each
>>>> environment, so I don't expect any more build fixes.
>>>>
>>>> Time to create a release candidate.
>>>
>>> great. I'll try to build 4.1.3 on Fedora 21 with the release options. Of
>>> course it's not the official baseline system. But maybe good enough to
>>> see if it's working.
>>
>> I get a problem with ant:
>>
>> Configure error message says the required version is >= 1.7.0.
>>
>> ant is installed with version 1.9.4. So, newer than the required 1.7.0.
>> I've also set the symlink "ant -> /usr/bin/ant" and executing configure
>> includes the "--with-ant-home=$HOME/ant" option.
>>
>> What else is needed to run configure successfully?
>
> I don't know why but after starting over and prepared the build again,
> it's now working.
>
> Finally I got a AOO 4.1.3 with release options - but only en-US. I used
> the following varaible + value in the build script:
>
> LANG="de en-US fr pt ja"
>
> OK, something for tomorrow.

the language option seems to be a problem with the build script:

Not OK:
--with-lang="${LANGS}"

OK:
--with-lang="de en-US fr pt ja"

BTW:
Ratscan shows the following files without correct header:
- main/LinuxX64-64Env.Set
- main/LinuxX64-64Env.Set.sh
- main/autom4te.cache/output.0
- main/autom4te.cache/requests
- main/autom4te.cache/traces.0
- main/config.log
- main/config.params
- main/configure
- main/warn


Something to add to "main/rat-excludes"?

Marcus


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message