openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "John D'Orazio" <john.dora...@cappellaniauniroma3.org>
Subject Re: building on Windows 10 breaks at guistdio.exe
Date Tue, 20 Sep 2016 01:22:40 GMT
I wound up building in stages, since the build was breaking here and there.
I just picked it up from where it left off as I fixed things. So I don't
have a single output... unless there is a log file that collects various
build stages together into one single output?
I would also recommend installing as many packages in cygwin as possible
without going through the extra step of installing lynx or apt-cyg... While
that does make the environment more similar to a linux build environment,
it's still an extra step and I believe it could be indicated as a second
possibliity. Somewhere in the Step by Step guide I added which packages to
choose in the cygwin interface if installing them from the cygwin
interface. I think installing the packages from the cygwin interface should
be indicated as the first step to take when first installing cygwin, adding
all the necessary packages along with the first install.
The only package I couldn't find from the cygwin interface was the Perl
LWP::UserAgent package, so I installed that using "cpan -i LWP::UserAgent".


On Tue, Sep 20, 2016 at 12:25 AM, Patricia Shanahan <pats@acm.org> wrote:

> Congratulations! I'm about to do a Windows 10 build on a new machine, so
> please make sure the step-by-step incorporates all that you learned in the
> process.
>
> I have a specific test I would like run. The current release process calls
> for doing the Windows builds on Windows 7. I am wondering if that is
> necessary. Could you test your Windows 10 build on a Windows 7 machine? Or
> send me the output - that may be quicker than waiting for my Windows 10
> build to go through.
>
>
> On 9/19/2016 1:46 PM, John D'Orazio wrote:
>
>> I have now successfully completed the build on Windows 10, and after
>> changing the install path of NSIS to one without spaces, packaging also
>> completed successfully. I have added "Windows 10" alongside "Windows 7"
>> and
>> "Windows 8.1" in the Step by Step guide.
>>
>> On Mon, Sep 19, 2016 at 7:50 PM, Patricia Shanahan <pats@acm.org> wrote:
>>
>> I had installed 64-bit Cygwin installed here before I started on compiling
>>> AOO. I hit problems, and had to go to the recommended 32-bit Cygwin.
>>>
>>> However, things have changed a bit since then, so it may be worth seeing
>>> if it works.
>>>
>>> On 9/19/2016 8:59 AM, John D'Orazio wrote:
>>> ...
>>>
>>> I also read somewhere that maybe using 64 bit cygwin can resolve the
>>>> occupied addresses and child_fork_process errors. I made an attempt at
>>>> getting the build environment ready in 64 bit cygwin but configure is
>>>> complaining about not finding Visual Studio C++, while this does not
>>>> happen
>>>> in 32 bit cygwin (I'm passing in the with-cl-home flag so it shouldn't
>>>> have
>>>> any problem finding it... I'm reading it has something to do with
>>>> registry
>>>> keys, idk I have to look into this better).
>>>>
>>>> ...
>>>
>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>
>>>
>>>
>>
>>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>


-- 
John R. D'Orazio

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message