openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Marcus <marcus.m...@wtnet.de>
Subject Re: Impress problem on linux?
Date Fri, 03 Feb 2017 20:42:02 GMT
Am 03.02.2017 um 20:56 schrieb Rory O'Farrell:
> Before I raise an issue on Bugzilla, I would like confirmation of the following problem:
>
> Using AOO 4.1.3 running on Xubuntu 16.04.1 I am not able to get Impress to play embedded
videos.  Any attempt to embed an .avi or an .mpg file is blocked by "The format of the selected
file is not supported" message and the file will not insert on the slide.  The .avi and .mpg
files play perfectly using the system video player (Parole) or VLC.  From memory this problem
occurred with AOO 4.0.0 - I have older presentations prepared in 2008 in which these embeddings
worked correctly, but such presentations do not play in current AOO 4.1.3.  I have tried a
number of different .avi and .mpg files, all to no avail within Impress.
>
> I have checked using the same multimedia files on AOO 4,1.3 running on Windows XP - they
work correctly
>
> My workaround is to insert a hyperlink to the .avi/.mpg files, which calls the system
video player.  This is a bit clunky, but at least the videos get shown.
>
> Would other users please confirm if this problem shows up on other linux versions (please
indicate linux distro and version) so that I can post as detailed an issue as possible on
Bugzilla.

https://bz.apache.org/ooo/show_bug.cgi?id=30776

IMHO it's the old Java Media Framework issue. In former Sun times the 
JMF [1] was choosen for Linux-based OS to manage multimedia files. Maybe 
it was decided to use a Java-based implementation instead of a 
Linux-native one like gstreamer. But at the end I don't know why. At the 
moment it is as it is.

I don't know if the JMF functions are still part of a current JRE. If 
not then we have a possible root cause that it is no longer working.

PS:
If you want to know, I'm working on Fedora 25 and AOO 4.1.3.

[1] https://en.wikipedia.org/wiki/Java_Media_Framework

Marcus


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message