openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Seidel <matthias.sei...@hamburg.de>
Subject Re: Strange error while building OO for windows
Date Sun, 14 May 2017 22:54:38 GMT
Hi Pavel,

Did you update the wiki accordingly?

If you don't have a MediaWiki (MWiki) account, you can request one...

Regards, Matthias


Am 03.05.2017 um 00:47 schrieb Pavel Belski:
> I tried to build OpenOffice from svn's AOO413 tag today, this time
> successful.
>
> Still i have to say that the wiki page with step-by-step guide has some
> errors that i had to deal with(or it's outdated a bit).
>
> Things that I encountered so far:
> 1. Suggested ./configure option list in the wiki is missing a compulsory
> "--disable-directx" option(in case you are not building with DirectX of
> course). This is a minor complaint, as the ./configure script will inform
> you about missing options.
> 2. AOO413 build process will terminate with an error when running javadoc
> on some Java sources - most likely due to this breaking change in JDK8:
> http://blog.joda.org/2014/02/turning-off-doclint-in-jdk-8-javadoc.html. As
> result, building AOO413 with jdk8 seems impossible if there isn't an easy
> way to forward -Xdoclint:none option to javadoc. JDK 7 works.
> 3. It could be helpful to write somewhere in build instructions that dmake
> doesn't try to rebuild failed modules automatically if they aren't
> recognised as "changed". I only noticed this while reading
> https://wiki.openoffice.org/wiki/Debug_Build_Problems, and AFAIK every
> other build system behaves differently(nmake, cmake/qmake, make ...)
>
> Building with symbols/debug mode enabled right now, should finish by
> tomorrow morning. Then i'll do something with it.
>
> 2017-05-01 13:50 GMT+02:00 Pavel Belski <genosimple@gmail.com>:
>
>> Hi all,
>>
>> currently i'm trying to build Open Office from svn sources, closely
>> following the guide in https://wiki.openoffice.org/wiki/Documentation/
>> Building_Guide_AOO/Step_by_step#Windows_7.2C_Windows_8.1.2C_Windows_10.
>> The trunk revision i currently have is
>>
>> Pavel@Pavel-PC /cygdrive/c/oosources/aoo-trunk
>> $ svn info
>> Pfad: .
>> Wurzelpfad der Arbeitskopie: /cygdrive/c/oosources/aoo-trunk
>> URL: https://svn.apache.org/repos/asf/openoffice/trunk
>> Relative URL: ^/openoffice/trunk
>> Basis des Projektarchivs: https://svn.apache.org/repos/asf
>> UUID des Projektarchivs: 13f79535-47bb-0310-9956-ffa450edef68
>> Revision: 1793265
>> Knotentyp: Verzeichnis
>> Plan: normal
>> Letzter Autor: mseidel
>> Letzte geänderte Rev: 1793216
>> Letztes √Ąnderungsdatum: 2017-04-29 18:32:21 +0200 (Sa, 29. Apr 2017)
>>
>> Steps that are marked as "optional" on the Wiki page i skipped except for
>> usage of dbghelp.dll(i configured with --enable-dbgutil). While trying to
>> build with "build --all" everything goes fine until this:
>>
>> =============
>> Building module gtest
>> =============
>>
>> Entering /cygdrive/c/oosources/aoo-trunk/ext_libraries/gtest
>>
>> mkdir: cannot create directory './wntmsci12/misc/build/gtest-1.7.0/':
>> File exists
>> C:/oosources/aoo-trunk/main/solenv/gbuild/Package.mk:28: ***
>> gb_Deliver_deliver: file does not exist in solver, and cannot b.  Stop.red:
>> /cygdrive/c/oosources/aoo-trunk/main/solver/420/
>> wntmsci12/inc/gtest/gtest.h
>> dmake:  Error code 2, while making './wntmsci12/misc/build/so_
>> built_oo_gtest'
>>
>> 1 module(s):
>>         gtest
>> need(s) to be rebuilt
>>
>> Reason(s):
>>
>> ERROR: error 65280 occurred while making /cygdrive/c/oosources/aoo-
>> trunk/ext_libraries/gtest
>>
>> When you have fixed the errors in that module you can resume the build by
>> running:
>>
>>         build --all:gtest
>>
>> As i understand it couldn't build some module and so doesn't find it on
>> the "deliver" step. The thing is, i don't see any compiler/linker error
>> messages and so have no idea what's up with this and where do i even start
>> trying to figure it out i also have no clue. Is this even something wrong
>> on my end or perhaps the svn trunk i have is unbuildable. What is OO dev
>> policy on acceptable build status of svn trunk revisions?
>>
>> Any ideas on what i should do next?
>>



Mime
View raw message