openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pavel Belski <genosim...@gmail.com>
Subject Re: Strange error while building OO for windows
Date Fri, 05 May 2017 15:24:58 GMT
Building the current revision of 4.1.4 right now, it will take several
hours but for now it's looking good.
I will inform you as soon as it is ready

2017-05-04 19:17 GMT+02:00 Matthias Seidel <matthias.seidel@hamburg.de>:

> Hi Pavel,
>
> I encountered exactly the same error in trunk but didn't go further on.
> Perhaps it is related to the changes regarding gbuild?
>
> Maybe you want to give the 4.1.4 branch a try?
>
> https://svn.apache.org/repos/asf/openoffice/branches/AOO414/
>
> Regards, Matthias
>
>
> Am 01.05.2017 um 13:50 schrieb Pavel Belski:
> > Hi all,
> >
> > currently i'm trying to build Open Office from svn sources, closely
> > following the guide in
> > https://wiki.openoffice.org/wiki/Documentation/Building_
> Guide_AOO/Step_by_step#Windows_7.2C_Windows_8.1.2C_Windows_10.
> > The trunk revision i currently have is
> >
> > Pavel@Pavel-PC /cygdrive/c/oosources/aoo-trunk
> > $ svn info
> > Pfad: .
> > Wurzelpfad der Arbeitskopie: /cygdrive/c/oosources/aoo-trunk
> > URL: https://svn.apache.org/repos/asf/openoffice/trunk
> > Relative URL: ^/openoffice/trunk
> > Basis des Projektarchivs: https://svn.apache.org/repos/asf
> > UUID des Projektarchivs: 13f79535-47bb-0310-9956-ffa450edef68
> > Revision: 1793265
> > Knotentyp: Verzeichnis
> > Plan: normal
> > Letzter Autor: mseidel
> > Letzte geänderte Rev: 1793216
> > Letztes √Ąnderungsdatum: 2017-04-29 18:32:21 +0200 (Sa, 29. Apr 2017)
> >
> > Steps that are marked as "optional" on the Wiki page i skipped except for
> > usage of dbghelp.dll(i configured with --enable-dbgutil). While trying to
> > build with "build --all" everything goes fine until this:
> >
> > =============
> > Building module gtest
> > =============
> >
> > Entering /cygdrive/c/oosources/aoo-trunk/ext_libraries/gtest
> >
> > mkdir: cannot create directory './wntmsci12/misc/build/gtest-1.7.0/':
> File
> > exists
> > C:/oosources/aoo-trunk/main/solenv/gbuild/Package.mk:28: ***
> > gb_Deliver_deliver: file does not exist in solver, and cannot b.
> Stop.red:
> > /cygdrive/c/oosources/aoo-trunk/main/solver/420/
> wntmsci12/inc/gtest/gtest.h
> > dmake:  Error code 2, while making
> > './wntmsci12/misc/build/so_built_oo_gtest'
> >
> > 1 module(s):
> >         gtest
> > need(s) to be rebuilt
> >
> > Reason(s):
> >
> > ERROR: error 65280 occurred while making
> > /cygdrive/c/oosources/aoo-trunk/ext_libraries/gtest
> >
> > When you have fixed the errors in that module you can resume the build by
> > running:
> >
> >         build --all:gtest
> >
> > As i understand it couldn't build some module and so doesn't find it on
> the
> > "deliver" step. The thing is, i don't see any compiler/linker error
> > messages and so have no idea what's up with this and where do i even
> start
> > trying to figure it out i also have no clue. Is this even something wrong
> > on my end or perhaps the svn trunk i have is unbuildable. What is OO dev
> > policy on acceptable build status of svn trunk revisions?
> >
> > Any ideas on what i should do next?
> >
>
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message