openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Damjan Jovanovic <dam...@apache.org>
Subject Re: OS/2 error running unopkg.bin while packaging
Date Sat, 23 Feb 2019 00:22:03 GMT
Hi

There were a lot of changes to UNO-related modules in the past few months,
due to both the Win64 port and the gbuild port. It's possible something
broke for OS/2 in the process.

I suggest a bisection test.

Sorry
Damjan



On Fri, Feb 22, 2019 at 12:52 PM Yuri Dario <yd@os2power.com> wrote:

> Hi,
>
> I have a strange error while packaging the current AOO42X tree: I'm
> getting
>
> Error: ERROR:
> F:/rd/AOO/aoo42x/main/instsetoo_native/os2gcci.pro/Apache_OpenOffi
> ce/archive/install/en-US_inprogress/Apache_OpenOffice_4.2.0_os2gcci_in
> stall-arc_
> <http://os2gcci.pro/Apache_OpenOffice/archive/install/en-US_inprogress/Apache_OpenOffice_4.2.0_os2gcci_install-arc_>
> en-US/OpenOffice 4/program/unopkg.bin sync --verbose
> -env:UNO_JAVA_JFW_ENV_JREHO
> ME=true 2>&1 | failed!
>
> in the log file I can see
>
> ERROR: cannot initialize UCB!
> Exception details:
> (com.sun.star.uno.RuntimeException) { { Message = "cannot initialize
> UCB!", Cont
> ext = (com.sun.star.uno.XInterface) @0 } }
>
>
> and debugging shows that the problem is related to file path length.
> Moving the directory to a shorter path makes unopkg.bin to work.
>
> But aside this, I wonder what does this action at package time, since
> the resulting package seems to be still working. Bundled extensions
> are loaded correctly and adding extensions works too.
>
> Ideas?
>
> thanks,
>
> Yuri
>
>
>
>
> --
> Bye,
>
>         Yuri Dario
>
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message