openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Don Lewis <truck...@apache.org>
Subject Re: Bootstrap?
Date Tue, 05 Feb 2019 02:21:12 GMT
I'm not sure about Windows, but on all the other platforms it is only
needed to build the optional odk.

On  3 Feb, Peter Kovacs wrote:
> The DLL is also an requirement to be there. Somewhere it says why.
> 
> On 03.02.19 16:45, Pedro Lino wrote:
>> Hi Nikhil, all
>>
>> I forgot to mention that I'm building now (as I did before) under Ubuntu 16.04 x64
so I don't need any dll
>> Any ideas what happened to bootstrap? Should I simply chmod and execute bootstrap.1?
>> Should I modify the step-by-step guide?
>>
>> Regards,
>> Pedro
>>
>>>     On February 3, 2019 at 2:32 PM Nikhil Gupta < nikhilgupta360174@gmail.com
mailto:nikhilgupta360174@gmail.com > wrote:
>>>
>>>
>>>     Hi,
>>>     This is the same problem which occurred when I first install AOO,
>>>     For bootstraping the project,
>>>     First you have to completely satisfy all the General requirements which is
>>>     described in this thread-
>>>     https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO
>>>
>>>     especially unowinreg.dll which you have to save main/external/unowinreg
>>>
>>>     then follow this mail which i followed for configuration
>>>     Peter Kovacs < Petko@apache.org mailto:Petko@apache.org >
>>>
>>>     to dev
>>>     You need to do something like:
>>>
>>>     autoconf
>>>
>>>     ./configure
>>>     --with-epm-url=
>>>     https://sourceforge.net/projects/oooextras.mirror/files/epm-3.7.tar.gz
>>>     --with-dmake-url= https://sourceforge.net/projects/oooextras.mirror/files/dmake-4.12.tar.bz2
>>>     --with-lang="en-US de fr it pt ja"
>>>     --enable-wiki-publisher
>>>     --enable-verbose
>>>     --without-stlport
>>>     --enable-category-b
>>>     --enable-opengl
>>>     --enable-dbus
>>>     --without-junit
>>>     --with-package-format="installed archive deb"
>>>     --enable-bundled-dictionaries
>>>     --with-vendor=ASF buildbot - NOT FOR RELEASE
>>>     --with-build-version=%(today)s-Rev.%(got_revision)s
>>>
>>>     After that has been finished successfull you can bootstrap
>>>
>>>
>>>
>>>     On Sun, Feb 3, 2019 at 7:08 PM Pedro Lino < pedro.lino@mailbox.org mailto:pedro.lino@mailbox.org
> wrote:
>>>
>>>
>>>         > >         Hi all
>>>>     > 
>>>         > >         I have built AOO from source in previous versions using
the step-by-step
>>>>         guide
>>>>
>>>>     >     >
>>>         > >         https://wiki.openoffice.org/wiki/Documentation/Building_Guide_AOO/Step_by_step
>>>>     > 
>>>         > >         Currently (in trunk and all branches from
>>>>         https://svn.apache.org/repos/asf/openoffice/) there is no bootstrap
file
>>>>         (only bootstrap.1 which is not set to execute) so
>>>>
>>>>     > 
>>>         > >         ./bootstrap
>>>>     > 
>>>         > >         doesn't work. Oddly enough I downloaded build 4.1.5
which I build
>>>>         successfully in the past but it only contains bootstrap.1
>>>>
>>>>     > 
>>>         > >         Am I missing something?
>>>>     > 
>>>         > >         Regards,
>>>>         Pedro
>>>>
>>>>     > 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
> For additional commands, e-mail: dev-help@openoffice.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message