openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Seidel <matthias.sei...@hamburg.de>
Subject Re: AOO 4.2 and OpenSymbol font
Date Tue, 05 Mar 2019 10:23:51 GMT
Hi Dave,

Can you also have a look at "Weierstraß-p" (Unicode U+2118).
In Writer and Math (only Windows, not Linux) the descender appears
slightly truncated.

Also, on Windows 10 OpenSymbol seems to be substituted by some MS font.
Windows 7 still shows OpenSymbol.
That might be a bug in Windows 10 but maybe we can get around this somehow.

Regards,

   Matthias

Am 05.02.19 um 02:53 schrieb Dave Fisher:
> Hi -
>
>> On Jan 30, 2019, at 2:32 PM, Matthias Seidel <matthias.seidel@hamburg.de> wrote:
>>
>> Hi Dave,
>>
>> Am 30.01.19 um 23:07 schrieb Dave Fisher:
>>> Hi -
>>>
>>>> On Jan 30, 2019, at 1:36 PM, Matthias Seidel <matthias.seidel@hamburg.de>
wrote:
>>>>
>>>> I had a look at the patched font and it is based on an old version (1.7
>>>> ?). At the moment we ship version 2.4.3.
>>>>
>>>> A general overhaul of that font would be needed. Do we have some font
>>>> specialists in our PMC or the ASF?
>>> I am very, very rusty. (About 15 years)  Point me towards some sources and I’ll
see if I can help.
>> What we have in our source is the TTF itself and an older SFD:
>>
>> https://svn.apache.org/repos/asf/openoffice/trunk/main/extras/source/truetype/symbol/
<https://svn.apache.org/repos/asf/openoffice/trunk/main/extras/source/truetype/symbol/>
> I see. I did a quick look and comparison with FontBook on my Mac. They are definitely
different. I am not even sure that the patched font from the Forum is encoded the same way
as the sample shows different characters.
>
> From the thread it looks like the patched font has misplaced the Greek Letters. Let me
see if I can provide a version 2.5 of OpenSymbol that can find the updated square root and
brackets while preserving the encoding.
>
> I’ve used FontForge to play with Fonts, but I cannot get it to work on my current macOS.
I do have a version of 10.7 which I will try later this week.
>
> Regards,
> Dave
>
>>> Regards,
>>> Dave
>>>
>>>> Regards,
>>>>
>>>>   Matthias
>>>>
>>>>
>>>> Am 30.01.19 um 22:28 schrieb Peter Kovacs:
>>>>> Jim, Matthias can you look into this? Imho it is a simple refresh of
the
>>>>> Font. (If we ship it.)
>>>>>
>>>>> On 29.01.19 11:13, FR web forum wrote:
>>>>>> Hello list,
>>>>>> It seems that Open Symbol font is not up to date.
>>>>>> Read: https://bz.apache.org/ooo/show_bug.cgi?id=127110
>>>>>> martin_g provide a patched font in this thread:
>>>>>> https://forum.openoffice.org/en/forum/viewtopic.php?f=12&t=67772&p=360368#p360385
>>>>>> Is it possible to embed this for next build?
>>>>>>
>>>>>> ---------------------------------------------------------------------
>>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>>>>
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>>>
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
>>> For additional commands, e-mail: dev-help@openoffice.apache.org
>>>
>


Mime
View raw message