openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michele Denber <mden...@gmx.com>
Subject Re: OO configure fails: Possible unintended interpolation of @ENABLE
Date Wed, 26 Jun 2019 16:13:20 GMT
>
> Subject: 	Re: OO configure fails: Possible unintended interpolation of
> @ENABLE
> Date: 	Tue, 25 Jun 2019 22:02:17 +0200
> From: 	Peter <legine@posteo.de>
> To: 	dev@openoffice.apache.org, Michele Denber <mdenber@gmx.com>
>
>
>
> Hello Michele,
>
> Is there no cups on Solaris?
Hi Peter.  That's actually not a simple question.  Solaris 10 originally
shipped with CUPS.  Then Sun and Apple got into some sort of patent tiff
and Sun removed CUPS from Solaris.  Then they made up so Sun put CUPS
back in.  My version (update 13) is supposed to have CUPS but I don't
see it where it's supposed to be (/opt/sfw/).  But you can get CSWcups
from OpenCSW, so that's what I did, but it didn't help.
> Have you tried later versions like 4.1.6?
That turned out to be the answer.  I downloaded 4.1.6 and it configured
fine.  But now I'm stuck in ./bootstrap.  I get:

# pwd
/export/home/denber/aoo-4.1.6/main
# ./bootstrap
ERROR: no destination defined! please set TARFILE_LOCATION! at
/export/home/denber/aoo-4.1.6/main/solenv/bin/download_external_dependencies.pl
line 611.
*** Error downloading external dependencies, please fix the previous
problems and try again ***

It isn't clear to me what that means so I tried:

# setenv TARFILE_LOCATION
/export/home/denber/apache-openoffice-4.1.6-r1844436-src.tar
# export TARFILE_LOCATION
# echo $TARFILE_LOCATION
/export/home/denber/apache-openoffice-4.1.6-r1844436-src.tar


But that didn't help.  The code in question (in
download_external_dependencies.pl) is this:

ub CheckDownloadDestination ()
{
     my $destination = $ENV{'TARFILE_LOCATION'};
     die "ERROR: no destination defined! please set TARFILE_LOCATION!"
if ($destination eq "");

     if ( ! -d $destination)
     {
         File::Path::make_path($destination);
         die "ERROR: can't create \$TARFILE_LOCATION" if  ! -d $destination;
     }
}

What am I doing wrong?

             - Michele



Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message