openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Matthias Seidel <matthias.sei...@hamburg.de>
Subject Re: [openoffice] 03/03: Fixes from upstream for newer GCC
Date Sat, 02 Nov 2019 18:54:54 GMT
Hi Ariel,

Am 02.11.19 um 18:57 schrieb Matthias Seidel:
> Hi Ariel,
>
> Am 02.11.19 um 18:49 schrieb Ariel Constenla-Haile:
>> On Sat, Nov 2, 2019 at 5:53 AM Peter Kovacs <Petko@apache.org> wrote:
>>> On Windows the issue is that the Git() command checks out the data at a
>>> position where cygwin does not see it.
>>>
>>> On the other hand if I pass the command directly no checkout happens.
>> It's always useful to see the logs:
>> https://ci.apache.org/builders/openoffice-win7/builds/37/steps/git%20clone%20under%20cygwin/logs/stdio
>>
>> + cd /home/buildslave
>> ...
>> + git clone --single-branch --branch trunk
>> https://gitbox.apache.org/repos/asf/openoffice.git build
>> fatal: destination path 'build' already exists and is not an empty directory.
>>
>> You have to cd to the right dir, quite strange some line below you
>> seem to do so...
>> You also removed the svn revision stuff but left got_revision.
>> It looks like the underlying OS was changed from Win7 32 bits to Win10
>> 64 bits, that's good news, the buildbot is capable of building
>> releases.
> Yes, Windows was updated some years ago, but we didn't change the names
> of the builbots... ;-)
>> Quite strange you changed the name (aoo - openoffice) but not the win7 ;)
>>
>> Now the buildbot stops due to missing NASM
>> https://ci.apache.org/builders/openoffice-win7/builds/40/steps/configure/logs/stdio
>> checking nasm.exe assembler path... checking for nasm.exe... no
>> configure: error: NASM is required to build on Windows, please install
>> or use --with-nasm-home
>> program finished with exit code 1
> NASM is a new requirement now. I think it was related to the updated
> OpenSSL version.
>> I don't have any machine with Windows to build, so please someone
>> building master/trunk on Windows (Matthias?) open a jira ticket
>> requesting to install NASM (once installed, the shell command should
>> include the new switch).
> I will do so!

Done:

https://issues.apache.org/jira/browse/INFRA-19373

I have also added you to our Slack channel, I hope you don't mind... ;-)

Matthias

>
> Regards,
>
>    Matthias
>
>> Regards


Mime
View raw message