openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Robley <robley.dav...@gmail.com>
Subject 4.2.0 Error starting Slackware 14.2 64 bit
Date Fri, 10 Jan 2020 08:50:34 GMT
OS - Slackware 14.2 64 bit

Download location - https://ci.apache.org/projects/openoffice/install/41x/

Downloaded file -

Apache_OpenOffice_4.2.0_Linux_x86-64_install-rpm_en-US_2020-01-05_12:45:50_5a80ab836302b0f575229ae49f451128d5c5932a.tar.gz

My install process:

Extracted the contents; cd to the RPM directory and used rpm2tgz to 
convert RPM files to a format compatible with Slackware's installer 
pkgtool; use pkgtool to install the application. This is pretty much how 
I have always installed AOO.

If I start AOO from the command line using my existing profile, I get an 
error on the command line javaldx: invalid settings. User must select a 
JRE from options dialog!

followed by a dialog box with the error message The application cannot 
be started. exception occurred raising singleton 
"/singletons/com.sun.star.deployment.ExtensionManager": loading 
component library failed: 
file:///opt/openoffice4/program/../program/deployment.uno.so

If I remove my profile the error message on the command line changes to 
Exit 77 /opt/openoffice4/program/soffice

followed by the same dialog box error.

I note that a .lock file is left in the top level of the profile structure.

I can roll back to AOO420m2 Build 9821 dated 2019-10-24 with no problems.

Am I missing something simple?


Cheers
-- 
David Robley

We're staying together for the sake of the cats.
  


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message