openoffice-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From David Robley <robley.dav...@gmail.com>
Subject Re: 4.2.0 Error starting Slackware 14.2 64 bit
Date Sun, 12 Jan 2020 08:00:01 GMT
Thank you for your reply: responses inline below.

On 12/1/20 5:35 pm, Peter Kovacs wrote:
> I am not sure about the issue you are facing.
>
> Have you Java installed?
Yes - but I hadn't added it to AOO; I did that in the working version, 
then uninstalled again, completely wiping anything under 
/opt/openoffice4 and re-installed. Now I get a different dialog box error:
The application cannot be started.
loading component library failed: 
file:///opt/openoffice4/program/../program/expwrap.uno.so
> How did you delete the profile?
Simply by renaming ~/.openoffice/4/user
> If the base directory still exist it might be problematic. I am not sure.
As I mentioned above, the base directory /opt/openoffice4 was empty. I 
failed to mention that I use the Slackware package to remove the old 
version before installing the new.
>   
>
>
> Am 10. Januar 2020 09:50:34 MEZ schrieb David Robley <robley.davide@gmail.com>:
>> OS - Slackware 14.2 64 bit
>>
>> Download location -
>> https://ci.apache.org/projects/openoffice/install/41x/
>>
>> Downloaded file -
>>
>> Apache_OpenOffice_4.2.0_Linux_x86-64_install-rpm_en-US_2020-01-05_12:45:50_5a80ab836302b0f575229ae49f451128d5c5932a.tar.gz
>>
>> My install process:
>>
>> Extracted the contents; cd to the RPM directory and used rpm2tgz to
>> convert RPM files to a format compatible with Slackware's installer
>> pkgtool; use pkgtool to install the application. This is pretty much
>> how
>> I have always installed AOO.
>>
>> If I start AOO from the command line using my existing profile, I get
>> an
>> error on the command line javaldx: invalid settings. User must select a
>>
>> JRE from options dialog!
>>
>> followed by a dialog box with the error message The application cannot
>> be started. exception occurred raising singleton
>> "/singletons/com.sun.star.deployment.ExtensionManager": loading
>> component library failed:
>> file:///opt/openoffice4/program/../program/deployment.uno.so
>>
>> If I remove my profile the error message on the command line changes to
>>
>> Exit 77 /opt/openoffice4/program/soffice
>>
>> followed by the same dialog box error.
>>
>> I note that a .lock file is left in the top level of the profile
>> structure.
>>
>> I can roll back to AOO420m2 Build 9821 dated 2019-10-24 with no
>> problems.
>>
>> Am I missing something simple?
>>
>>
>> Cheers
>> -- 
>> David Robley
>>
>> We're staying together for the sake of the cats.
>>   


Cheers
-- 
David Robley

Why is it called tourist season if we can't shoot them?
  


---------------------------------------------------------------------
To unsubscribe, e-mail: dev-unsubscribe@openoffice.apache.org
For additional commands, e-mail: dev-help@openoffice.apache.org


Mime
View raw message