openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Großkopf <rob...@familiegrosskopf.de>
Subject Re: Datenbank Feld Betrag
Date Sat, 29 Mar 2014 20:17:28 GMT
Hallo Rolf, *,
> 
> Seit ein paar Tagen bin ich Nutzer von Open Office. Bei der Erstellung 
> einer Datenbank ergab sich folgendes Problem.
> Das Feld Betrag wurde von mir formatiert mit Zahlen, Währung, zwei 
> Komastellen.
> Der eingetragene Betrag z.B. 345,67 wurde auch beim weiterschalten auf 
> die nächste Feldreihe übernommen.
> Sobald man jedoch in die Felder Betrag zurückkehrt wird aus 345,67 
> 345,00 ????

ich habe gerade erst wieder einmal in der Liste vorbeigeschaut und die
Antworten gelesen. Vermute einmal, dass das Problem dadurch für Rolf
nicht gelöst ist.

Rolf, was hast Du bei der Tabellendefinition für ein Zahlenformat
gewählt? Standardmäßig wird bei den Nachkommastellen nicht automatisch
eine "2" eingetragen. Da steht dann eine "0". Wenn Du die Tabelle zum
bearbeiten öffnest, dann schaue einmal auf die Nachkommastellen.
Das Zahlenformat dürfte so etwas wie "Dezimal" sein.
Die Formatierung dann "Währung €".

Solange Du Dich bei der Dateneingabe in einer Zeile (Datensatz) bewegst
nehmen die Felder klaglos alle Eingaben hin. Wenn das Ganze
abgespeichert ist, dann kommt die Einstellung der Datenbank zum Tragen.
Und die Datenbank lässt bei Dir offensichtlich keine Nachkommastellen
zu, weil sie vermutlich nicht in der Tabelle definiert sind.

Gruß

Robert

---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message