openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wolfgang Jäth <jawo.ml.hams...@arcor.de>
Subject Re: Bereich variabel adressieren
Date Thu, 28 May 2015 14:05:25 GMT


Am 28.05.2015 um 11:52 schrieb technik:
> Hallo,
> 
> Ich möchte gerne einen Zellbereich variabel adressieren. Das heißt, je 
> nach Formelergebnis einen anderen Bereich.
> 
> Beispiel:
> 
> ich habe eine Tabelle1 mit Daten in B1 bis C10
> B    C
> 1    1
> 2    3
> 3    5
> 4    8
> 5    5
> 6    8
> 7    6
> 8    7
> 9    5
> 10    8
> 
> In Tabelle 2 will ich jetzt einen Vergleich machen und die Zelle mit 5 
> suchen in Spalte C
> Vergleich("5";Tabelle1.C1:C10) ergäbe 3
> Jetzt will ich aber in Zeile 4 weitersuchen. Wie gebe ich den Bereich 
> dann variabel ein. Entstehen müsste
> Tabelle1.C4:C10. Das kann ich zwar mit Formeln abbilden, aber nicht als 
> suchmatrix.
> Adresse() Hilft auch nicht weiter, weil es da nur um eine Zelle geht.

E1:	=VERGLEICH(5;C1:C10;0)
E2:	=ADRESSE(ZEILE(C1)+E1;SPALTE(C1))&":"&"C10"
E3:	=VERGLEICH(5;INDIREKT(E2);0)+E1

Bei Bedarf kannst Du das "C10" in E2 natürlich auf die gleiche Weise
verschieben

Wolfgang
-- 

---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message