openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Semmel <sem...@gmx.ch>
Subject Fehlerabfrage in CALC mit "WENN-ODER"
Date Wed, 11 Nov 2015 12:58:18 GMT
Fehlerabfrage in CALC:

Ist eine „ODER“ Verknüpfung in Verbindung mit „ISTFEHLER“ nicht möglich 
oder wo liegt mein Bock?

Gegeben sind zwei Tabellenblätter. Im ersten befindet sich eine 
Übersichtstabelle, in der verschiedene Jahre waagerecht (Zeile 4) und 
die Monate senkrecht (Spalte 1, ab Zeile 4) eingetragen sind. Über diese 
Zuordnung von Monat und Jahr suche ich nun im Tabellenblatt 2 („Daten“) 
nach den entsprechenden Werten.

Weshalb aber gibt mir die folgende Formel ein #NV aus, wenn das 
entsprechende Datum nicht gefunden wird, *obwohl* ich das mit einem 
„ISTFEHLER“ versucht habe abzufangen?

=WENN(ODER(ISTFEHLER(SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0));SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;1)<1);"

";SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0))


„Ziehe“ ich die Formel auseinander und frage mit WENN (*ohne* ein 
„ODER“) ab, ob
a) ein Fehler besteht 
[=WENN(ISTFEHLER(SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0));" 
";SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0))], dann 
klappt das und die Zelle bleibt wie gewünscht leer und

b) der gesuchte Wert kleiner 1 ist 
[=WENN(SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;1)<1);" 
";SVERWEIS(DATUM(B$4;ZEILE(A5)-4;1);Daten.$I$3:$L2632;4;0))], dann 
klappt auch das für sich genommen, wenn das gesuchte Datum besteht. Aber 
„es geht“ in dem Augenblick nicht mehr (Ergebnis: #NV), wenn das Datum 
erst gar nicht gefunden wird (was mir in dieser entzerrten Konstellation 
auch klar ist).

Weshalb aber kann ich das mit der eingangs beschriebenen „=WENN(ODER 
...“ -Abfrage nicht abfangen und erhalte (bei nicht gefundenem Datum) 
immer ein #NV?
Wo liegt mein Fehler?

Liebe Grüße, Peter.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message