openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Wolfgang Jäth <jawo.ml.hams...@arcor.de>
Subject Re: Fehlerabfrage in CALC mit "WENN-ODER"
Date Thu, 12 Nov 2015 18:25:02 GMT
Am 12.11.2015 um 10:23 schrieb Semmel:
> 
> Wolfgang Jäth schrieb am 11.11.2015 um 18:04:
>> Am 11.11.2015 um 13:58 schrieb Semmel:
>>> Ist eine „ODER“ Verknüpfung in Verbindung mit „ISTFEHLER“ nicht möglich
>>> oder wo liegt mein Bock?
>> Also liefert ISTFEHLER das Ergebnis FALSCH zurück; das bedeutet, dass
>> die nächste Bedingung abgefragt werden muss, denn die könnte ja TRUE sein.
> 
> wie schon eben an Horst geschildert: da genau lag mein Denkfehler bzw. 
> meine irrige Annahme, weil ich dachte: "ist die eine ODER die andere 
> Bedingung zutreffend (ODER auch beide), dann ...". Ich hoffe, ich merke 
> mir diesen Unterschied bei Calc.  :)

Das ist auch so; nur werden halt grundsätzlich alle Bedingungen abgefragt.

> Ich will überhaupt nicht schleimen und ich werde das Folgende auch nur 
> einmal in dieser Liste sagen - und dann nie mehr. Aber wie schaffst Du 
> es immer wieder, Dich in die Konstrukte (bei zumeist nur kurzen 
> Schilderungen) so derart hinein zu versetzen?

Du kennst *meine* Formeln nicht ... <vbeg>

Wolfgang
-- 
=WENN($A14=""; ""; WENN(AutoMakro.$C$19=7; V14*1000; MAX(1; MIN(100000;
ABRUNDEN(WENN(V14<15; MAX(WENN($AutoMakro.$F$7=10; 90000; 0);
((299,9+(200*V14))/(AutoMakro.$C$18*100))); WENN(V14>84; MAX(WENN(ODER(
$AutoMakro.$F$7=4; $AutoMakro.$F$7>=9); 60; 0); ((20099,9-(200*V14))/
(AutoMakro.$C$18*100))); (100000*SIN(V14*PI()/100)))))))))

---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message