openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Oliver Brinzing <Oliver.Brinz...@gmx.de>
Subject Re: Fehler auf der Foren und Newsgroups Webseite
Date Mon, 18 Jul 2016 16:53:15 GMT
Hallo,

 > =WENN(E27>"21:00";E27;"24:00"-E27)   ergibt das richtige Ergebnis "0:56"

ich würde behaupten, Du muss die Zeiten erst mal in Werte umwandeln:

WENN(E27>ZEITWERT("21:00");ZEITWERT("24:00")-E27)

bevor du damit rechnen kannst

Schau Dir bitte mal die Website an:
http://www.ooowiki.de/CalcFunktionenDatum(2f)RechnenMitDatumUndZeit.html

Gruß
Oliver

Am 18.07.2016 um 16:27 schrieb Preisinger:
> Hallo zusammen,
>
> mit der Tabellenkalkulation von OO hatte ich bisher keine Probleme,
> selbst wenn diverse Formeln gebraucht wurden, fand ich bisher immer eine
> Lösung, doch dieses Mal komme ich nicht weiter:
>
> Meine Version ist bisher 3.3.
> Das Problem tritt in einer Zeittabelle auf, die Anwesenheitszeiten
> beinhaltet, die errechnel werden sollen, indem sie an Bedingungen
> geknüpft werden.
>
> Beispiel:
>
>
> 	*A* 	*B* 	*C* 	*D* 	*E* 	*F* 	*G* 	*H* 	*I* 	*J*
> 9 	*Datum* 	*Tag* 	*Bemerkung* 	*von* 	*bis* 	*Std.* 	*Summe* 	*Soll*
> *Diff.* 	*Su Diff.*
> 10 	1. 	Fr 	Feiertag 	05:00 	12:00 	14:00 	14:00 	8:00 	06:00 	06:00
> 11 	2. 	SA 	
> 	05:02 	14:00 	8:58 	22:58 	8:00 	00:58 	06:58
> 12 	3. 	SO 	
> 	05:04 	14:58 	9:54 	08:52 	8:00 	01:54 	08:52
> 13 	4. 	MO 	
> 	05:15 	14:16 	9:01 	17:53 	8:00 	01:01 	09:53
> 14 	5. 	DI 	
> 	05:12 	14:36 	9:24 	03:17 	8:00 	01:24 	11:17
> 15 	6. 	MI 	
> 	04:56 	14:45 	9:49 	13:06 	8:00 	01:49 	13:06
> 16 	7. 	DO 	krank 	
> 	
> 	
> 	
> 	
> 	
> 	13:06
> 17 	8. 	FR 	krank 	
> 	
> 	
> 	
> 	
> 	
> 	13:06
> 18 	9. 	SA 	krank 	
> 	
> 	
> 	
> 	
> 	
> 	13:06
> 19 	10. 	SO 	krank 	
> 	
> 	
> 	
> 	
> 	
> 	13:06
> 20 	11. 	MO 	krank 	
> 	
> 	
> 	
> 	
> 	
> 	13:06
> 21 	12. 	DI 	krank 	
> 	
> 	
> 	
> 	
> 	
> 	13:06
> 22 	13. 	MI 	krank 	
> 	
> 	
> 	
> 	
> 	
> 	13:06
> 23 	14. 	DO 	
> 	04:49 	12:29 	7:40 	07:40 	8:00 	23:40 	12:46
> 24 	15. 	FR 	
> 	04:47 	14:38 	9:51 	17:31 	8:00 	01:51 	14:37
> 25 	16. 	SA 	frei 	
> 	
> 	
> 	
> 	
> 	
> 	14:37
> 26 	17. 	SO 	frei 	
> 	
> 	
> 	
> 	
> 	
> 	14:37
> 27 	18. 	MO 	
> 	13:22 	23:04 	9:42 	09:42 	8:00 	01:42 	16:19
> 28 	19. 	DI 	
> 	13:30 	22:47 	9:17 	18:59 	8:00 	01:17 	17:36
> 29 	20. 	MI 	
> 	13:30 	23:43 	10:13 	05:12 	8:00 	02:13 	19:49
> 30 	21. 	DO 	
> 	13:30 	23:41 	10:11 	15:23 	8:00 	02:11 	22:00
>
>
> Legende:
>
> A:    Datum
> B:    Wochentag
> C:    Hinweise: Feiertatg = doppelte Stundenanzahl, sonst normale
> D:    Beginn Arbeitszeit lt. Stechuhr
> E:    Ende Arbeitszeit lt. Stechuhr
> F:    Anzahl der Stunden, errechnet mit der Formel: "E-D"
> G:    Summe der monatlichen Stunden
> H:    Soll-Arbeitszeit in Std.
> I:     Differenz der Ist-Std. F zu Soll-Std. H
> J:    Summe der Differenz-Std. mtl. Saldo
>
> Formeln:
>
> =WENN(D10="";"";WENN(D10<"6:00";"6:00"-D10;WENN(E10>"21:00";"24:00"-E10;"")))
> - diese Formel funktioniert einwandfrei
>
> die analoge Formel zur Berechnung der Spätstunden jedoch funktioniert nicht:
>
> =WENN(D27="";"";WENN(E27>"21:00";"24:00"-E27;""))   - diese Formel
> ergibt den Wert "16:38", bzw. den Wert "00:00" beim Weglassen der beiden "".
>
> Mit einer Umstellung der Formel (zu Testzwecken) jedoch funktioniert die
> Formel, wenn auch logisch falsch:
>
> =WENN(E27>"21:00";E27;"24:00"-E27)   ergibt das richtige Ergebnis "0:56"
>
> Außerdem trat bei der Addition der Stunden auf, dass die Stunden zwar
> richtig addiert werden, jedoch beim "Überlauf" über die 24:00 Std. die
> Zahlen wieder mit "1:00" beginnen und die Stunden nicht über die "24:00"
> hinaus angezeigt werden, obwohl sie "intern" für den PC richtig saldiert
> werden. Wie ist es möglich, diese Stundenanzahl korrekt darzustellen?
>
> Nach meinem bisherigen Verständnis funktioniert die logische Abfrage
> "größer als" nicht oder falsch, zumindest nicht in der gleichen Weise
> wie mit der Funktion "kleiner als".
> Bisherige Formeln mit der Funktion haben nach meiner Erinnerung immer
> richtig funktioniert, nur mit Zeitangaben hatte ich sie bisher nicht
> verwendet.
> Ich bitte daher um Prüfung und Rück-Info, ob und wo mein Fehler liegt,
> trotz intensiver Suche auf den Foren konnte ich dieses Problem nicht finden.
> Für die Hilfe im Voraus vielen Dank!
> Freundliche Grüße
>
> Gerold Preisinger
> E-Mail: preisinger@web.de
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message