openoffice-users-de mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jörg Schmidt <joe...@j-m-schmidt.de>
Subject Re: OOo-Benutzerverzeichnis und Makro-Liste "module1.xba"
Date Fri, 06 Oct 2017 09:21:14 GMT
> From: Helmut Schütz [mailto:helmut-schuetz@onlinehome.de] 
> Der Hintergrund meiner Frage: Bis zum letzten Update von OOo 
> (ich nutze 
> jetzt Apache Open-Office 4.1.3) konnte ich meine Makros problemlos 
> nutzen. Seitdem poppen beim Aufruf aller eigenen Makros 
> Fehlermeldungen 
> (z. B. siehe Anhang) auf, dass das Basic Script nicht gefunden werden 
> konnte. Meine Makro-Datei (Module1.xba mit dem korrekten Inhalt) ist 
> aber im Pfad 
> Users/Helmut/AppData/Roaming/OpenOffice/4/user/basic/Standard 
> vorhanden. 
> Nur scheint Writer darauf nicht zugreifen zu können, da beim Versuch, 
> die Makros über das Menü "Extras - Makros - Makros verwalten - 
> OpenOffice Basic... - Meine Makros - basic" aufzurufen, keine 
> Makros in 
> "Module 1" angezeigt werden.

nur allein durch das Vorhandensein der Module1.xba funktionieren die Makros und/oder Makroverwaltung
nicht zwingend, denn dazu sind _zumindestens_ noch die zwei Dateien (mit richtigem Inhalt)
nötig:

Users/Helmut/AppData/Roaming/OpenOffice/4/user/basic/dialog.xlc
Users/Helmut/AppData/Roaming/OpenOffice/4/user/basic/script.xlc

nötig.


Im Übrigen lässt sich das OO-Benutzerverzeichnis auch aus:

Extras-Einstellungen-OPenOffice-Pfade 

ablesen. Steht dort beispielsweise unter "AutoKorrektur" der Pfad:
C:\Users\...\AppData\Roaming\OpenOffice\4\user\autotext

ist das OO-Benutzerverzeichnis:
C:\Users\...\AppData\Roaming\OpenOffice\4\user


Gruß
Jörg



   


---------------------------------------------------------------------
To unsubscribe, e-mail: users-de-unsubscribe@openoffice.apache.org
For additional commands, e-mail: users-de-help@openoffice.apache.org


Mime
View raw message