perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Joshua Chamas <jos...@chamas.com>
Subject Re: Output?
Date Tue, 16 Oct 2001 21:06:10 GMT
Tim Pushor wrote:
> 
> The last page actually processes a transaction that could take up to 30
> seconds. The problem is that the user can navigate through the pages with no
> problem, but on the last page, a user will frequently get a 'document
> contains no data' error.
> 

Is there anything in your error_log about this?
Are there any clues if you set Debug to -1 ?
What is the error_log output for that error with 
Debug set to -1 for the error request?

Are you running the latest Apache::ASP ?  Try 
upgrading and see if it helps.

> 1) Could this be keep alive related?

? Maybe, I always have keep alives turned off, so 
can't really tell you.

> 2) I am processing the transaction before outputting anything (in case of
> error) - could this be the problem? Should it least output the Content-Type
> header? When does Apache::ASP output the header?
> 

Sure, but you would expect for an error condition in
an ASP script that there would be a server error 500,
not a null document.

--Josh

_________________________________________________________________
Joshua Chamas                           Chamas Enterprises Inc.
NodeWorks Founder                       Huntington Beach, CA  USA 
http://www.nodeworks.com                1-714-625-4051

---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message