perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Maurice Aubrey <maur...@hevanet.com>
Subject Re: Apache::ASP and debugging with Apache::DB
Date Mon, 25 Feb 2002 11:52:37 GMT
On Wed, Feb 20, 2002 at 12:42:36AM +1100, Christopher Forkin wrote:
> I hope this is not a FAQ. When I debug Apache::ASP web-pages with Apache::DB
> the debugger is not capable of displaying the source-code of the 
> perl-program
> underlying the ASP webpage (when using debugger commands such as "w" or 
> "l").
> It has no problems displaying the source-code of Perl-Modules referenced 
> from such
> pages. Am I missing something here? Can someone enlighten me on how to debug
> ASP pages with Apache::DB?

The reason for this is that Apache::ASP resets perl's idea of the
current line number and filename to make any errors reflect their true
location in the ASP scripts.  But the debugger doesn't seem to
like that.

Apache::Registry does this too, but if you take a look at Apache::DB
you'll notice that it sets $Apache::Registry::MarkLine = 0, which
suppresses that behavior when running under the debugger.

The quick fix is to remove the line numbering stuff.
The real fix is to make it configurable and maybe just honor the
$Apache::Registry::MarkLine value.

Maurice

---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message