perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Brown <st...@sprintmail.com>
Subject Re: ASP on Virtual Server
Date Thu, 22 Jan 2004 13:57:36 GMT
After doing the "rm -rf *" in the /tmp/asp statedir, I get the following when I run my Hello
World test.asp:

Can't call method "lock" on an undefined value at /usr/lib/perl5/site_perl/5.6.0/Apache/ASP/State.pm
line 310. Apache::ASP::State::AUTOLOAD('Apache::ASP::Application=HASH(0x83435a8)') called
at /home/webadmin/ptoc.org/register/global.asa line 14 Apache::ASP::Compiles::__ASP__home_webadmin_ptoc_org_registerx::Session_OnStart()
called at /usr/lib/perl5/site_perl/5.6.0/Apache/ASP.pm line 1510 require 0 called at /usr/lib/perl5/site_perl/5.6.0/Apache/ASP.pm
line 1510 Apache::ASP::Execute('Apache::ASP=HASH(0x8177c9c)', 'Session_OnStart') called at
/usr/lib/perl5/site_perl/5.6.0/Apache/ASP/GlobalASA.pm line 163 Apache::ASP::GlobalASA::ExecuteEvent('Apache::ASP::GlobalASA=HASH(0x816e08c)',
'Session_OnStart') called at /usr/lib/perl5/site_perl/5.6.0/Apache/ASP/GlobalASA.pm line 193
Apache::ASP::GlobalASA::SessionOnStart('Apache::ASP::GlobalASA=HASH(0x816e08c)') called at
/usr/lib/perl5/site_perl/5.6.0/Apache/ASP/StateManager.pm line 142 Apache::ASP::InitState('Apache::ASP=HASH(0x8177c9c)')
called at /usr/lib/perl5/site_perl/5.6.0/Apache/ASP.pm line 414 Apache::ASP::new('Apache::ASP',
'Apache=SCALAR(0x8177fc0)', '/home/webadmin/ptoc.org/register/test.asp') called at /usr/lib/perl5/site_perl/5.6.0/Apache/ASP.pm
line 181 Apache::ASP::handler('Apache=SCALAR(0x8177fc0)') called at /dev/null line 0 require
0 called at /dev/null line 0 , /usr/lib/perl5/site_perl/5.6.0/Apache/ASP.pm line 1514 

Since I'm on a virtual server hosted by globalservers.com, I'm limited as to what I can do.
 I do have su password, but, for example, I can't just reload and start over from a CD.  If
I mess up, then the globalserver people have to go in a reinitalize my viritural server back
to square one.  This puts me back with perl 5.6 and mod_perl installed using perl 5.6.  Then
it seems when I try to upgrade using CPAN I end up with a mess.  Is my project doomed?





-----Original Message-----
From: "Fagyal, Csongor" <concept@conceptonline.hu>
Sent: Jan 22, 2004 7:07 AM
To: Steve Brown <steve@sprintmail.com>
Subject: Re: ASP on Virtual Server

Steve Brown wrote:

>Even though installing Apache ASP into perl 5.6 seemed to work, it's flacky to say the
least.  Most of the time I hit my Hello World ASP with a new browser session, it fails with
verious errors.  I do a refresh and it usually works.  Most of the time I get this error.
>
>Bizarre copy of ARRAY in aassign at /usr/lib/perl5/5.6.0/Carp/Heavy.pm line 79. , /usr/lib/perl5/site_perl/5.6.0/Apache/ASP.pm
line 1514
>
Not a bad error message :-)

Try to rm -rf * your statedir. If it still doesn't work, I'd say 
recompile mod_perl with 5.8.

- Cs.



Steve Brown

---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message