perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Steve Brown" <st...@sprintmail.com>
Subject RE: ASP on Virtual Server
Date Thu, 22 Jan 2004 01:45:18 GMT
> -----Original Message-----
> From: Josh Chamas [mailto:josh@chamas.com]
> Sent: Wednesday, January 21, 2004 6:16 PM
> To: Steve Brown
> Cc: asp@perl.apache.org
> Subject: Re: ASP on Virtual Server
> 
> Fagyal, Csongor wrote:
> >>
> >> [Wed Jan 21 12:18:27 2004] [error] Can't locate Apache/ASP.pm in @INC
> >> (@INC contains: /usr/lib/perl5/5.6.0/i386-linux /usr/lib/perl5/5.6.0
> >> /usr/lib/perl5/site_perl/5.6.0/i386-linux
> >> /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl . /etc/httpd/
> >> /etc/httpd/lib/perl) at (eval 2) line 3.
> >>
> >> [Wed Jan 21 12:18:27 2004] [error] Undefined subroutine
> >> &Apache::ASP::handler called.
> >>
> >> I added this line above the <Files> tag in the .htaccess file
> >> PerlModule  Apache::ASP
> >>
> >> Now I get the following error in the error_log.
> >>
> >> [Wed Jan 21 12:25:47 2004] [alert] [client 208.24.179.29]
> >> /home/webadmin/ptoc.org/register/.htaccess: Can't locate Apache/ASP.pm
> >> in @INC (@INC contains: /usr/lib/perl5/5.6.0/i386-linux
> >> /usr/lib/perl5/5.6.0 /usr/lib/perl5/site_perl/5.6.0/i386-linux
> >> /usr/lib/perl5/site_perl/5.6.0 /usr/lib/perl5/site_perl . /etc/httpd/
> >> /etc/httpd/lib/perl) at (eval 5) line 3.
> >>
> >> It's not even trying to use my newly installed perl 5.8
> >>
> >>
> > I think you have to reinstall mod_perl using Perl 5.8. Or you might try
> > to set your @INC so that the "old" perl sees Apache::ASP (but I don't
> > think that's a good idea...)
> >
> > - Csongor
> >
> 
> Csongor is right, the mod_perl is currently tied to your old perl on the
> system.
> 
> Alternatively, you can also install Apache::ASP into your old perl 5.6,
> which is
> probably located at /usr/bin/perl
> 
> Regards,
> 
> Josh
> 
 
Perl 5.6 is in /usr/bin and perl 5.8 is in /usr/local/bin.

When I did the "cpan> install Bundle::Apache::ASP", I don't recall a choice
of which perl to install into.  How would I install Apache::ASP into perl
5.6?

Thanks to all who are trying to help me.  I really appreciate the help.
Steve Brown 




---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message