perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ruslan Appazov" <rus...@opta.com.ua>
Subject CGI.pm doesn't work propertly with $Request->Form object
Date Thu, 08 Jul 2004 10:02:44 GMT
Hi all!
I installed Apache 2.0.48(win32)/mod_perl 1.99 + Perl 5.8.3.
Before it's used Apache1.3.27/mod_perl1.27 + Perl 5.6.1.
There is Apache::ASP 2.57 on both platforms.
Everything works fine. Thanks to Josh Chamas.


But I found one problem on Apache2.
The example cgi.thm must show compatibly Apache::ASP and CGI.pm.
And there is a note at page: "Before, you couldn't do a
use CGI;
by itself, as it would try to read form input that had already been loaded
into $Request->Form(). Form input is now cached, and may be loaded into CGI
as well. ".
Yes, it's true on Apache1. But on Apache2 these rows don't do they must
(from cgi.htm):
-----------------------------------------------------------------
if (param()) {
    print "Your name is ",em($name),p,"\n",
    "The keywords are: ",em(join(", ",param('words'))),p,"\n",
    "Your favorite color is ",em(param('color')),"\n",
    hr;
}
-----------------------------------------------------------------
And simultaneously object $Request->Form returns values
$Request->Form('name'), $Request->Form('color') etc, if I insert print
operators in the script. Also script works fine if to use method GET
(default - POST). Other example script with CGI.pm and POST(file_upload.asp)
works normally, but there is not function param() - only $Request->Form.
What's a problem? Can somebody help?
Thanks in advance.

Ruslan Appazov.




---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message