perl-asp mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Warren Young <war...@etr-usa.com>
Subject Re: Apache::ASP Mod_perl
Date Fri, 17 Jul 2015 21:08:08 GMT
On Jul 17, 2015, at 1:16 PM, Cris Boisvert <Cris@usai.net> wrote:
> 
> Trying to get apache with asp and mod perl working.

On what platform?  Specifically, which versions of Apache, mod_perl, and Perl are you using?

> I get this error in the logs.
> 
> [asp] [1349] [error] error compiling test.asp: Can't modify constant item in scalar assignment
at /var/www/site/test.asp line 16, at EOF <--> , /usr/share/perl5/Apache/ASP.pm line
1466

I’ve never seen that one.  It means Apache::ASP couldn’t compile an *.asp or *.inc file,
but I couldn’t say why.

What I can tell you is that Apache::ASP really hasn’t been updated significantly since the
days when mod_perl was the standard way to deploy Perl web apps, which hasn’t been true
for quite some time now.  The Perl world has moved on to Plack/PSGI and FastCGI instead, and
mod_perl has been left to bit-rot.  It’s gotten to the point that RHEL 7 and its derivatives
no longer even include mod_perl.

While all of this can be worked around, I can’t recommend going to the trouble if you don’t
have a legacy code base to get working again, and not even then in most cases.

We ported our web app to Dancer.  It was quite a bit of work, but we’re very happy with
the new framework.

I wrote a longish review of Dancer as compared to Apache::ASP here on this list about a year
back: http://goo.gl/kDQB5b
---------------------------------------------------------------------
To unsubscribe, e-mail: asp-unsubscribe@perl.apache.org
For additional commands, e-mail: asp-help@perl.apache.org


Mime
View raw message