perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jobst Schmalenbach <jo...@barrett.com.au>
Subject Re: Apache upgrade 2.2 -> 2.4 and "PerlAuthenHandler Authen::Simple::IMAP"
Date Wed, 20 Feb 2019 05:11:39 GMT
On Tue, Feb 19, 2019 at 06:14:53PM -0800, Paul B. Henson (henson@acm.org) wrote:
> On 2/19/2019 6:02 PM, Jie Gao wrote:
> > Found this on CPAN:
> > 
> > Module  < Authen::Simple::IMAP   (DMARTIN/Authen-Simple-IMAP-0.1.2.tar.gz)
> 
> The last update for this module was in 2009; Apache 2.4 was released in
> 2012, so without even looking at the code I am fairly confident the module
> does not support it.
> 
> Authen::Simple::Apache, not Authen::Simple::IMAP itself. That one was last
> 

There are actually a few issues here and it's not

 - Authen::Simple::Apache
 - Authen::Simple::IMAP

It has to do with the .htaccess file, I just got a login box.
I saw this:

  https://www.gsp.com/cgi-bin/man.cgi?topic=Authen::Simple::Passwd

which has a different setup than the .htaccess I specified

  PerlModule Authen::Simple::Apache
  PerlModule Authen::Simple::Passwd
  PerlSetVar AuthenSimplePasswd_path "/etc/passwd"

  PerlAuthenHandler Authen::Simple::Passwd
  AuthType          Basic
  AuthName          "Protected Area"
  Require           valid-user

They are ACTUALLY specifying the MODULES which I did not do.


Need to play some hockey first .. BBL
Jobst






-- 
People without trees are like fish without clean water!

  | |0| |   Jobst Schmalenbach, General Manager
  | | |0|   Barrett & Sales Essentials
  |0|0|0|   +61 3 9533 0000, POBox 277, Caulfield South, 3162, Australia

Mime
View raw message