perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jobst Schmalenbach <jo...@barrett.com.au>
Subject Re: Apache upgrade 2.2 -> 2.4 and "PerlAuthenHandler Authen::Simple::IMAP"
Date Thu, 21 Feb 2019 03:55:58 GMT
On Thu, Feb 21, 2019 at 02:35:22AM +0000, Jie Gao (j.gao@sydney.edu.au) wrote:
> * Jobst Schmalenbach <jobst@barrett.com.au> wrote:
> 
> Not sure how you went with this issue, but you might want to try this instead:
> 
> <RequireAll>
>     Require user USER1 USER2
>     <RequireAny>
>         Require ip 127.0.0.1
>         Require host localhost
>         Require host THESERVER
>     </RequireAny>
> </RequireAll>
> 

Does not make a diffrence. If you read

  http://httpd.apache.org/docs/trunk/upgrading.html

it states a little bit further down related to the old "satisfy any" (which is what I want)

  2.4 configuration:
  AuthType Basic
  AuthBasicProvider file
  AuthUserFile /example.com/conf/users.passwd
  AuthName secure
  # Implicitly <RequireAny>
  Require valid-user
  Require ip 127.0.0.1

So it's implicit, which actaully I understand.


As I said too, I have a login box (couple of email before yours) ... so it is actually loading
everything as expected.
I am currently fixing this:

  Using the default of SSL_verify_mode of SSL_VERIFY_NONE for client
  is deprecated! Please set SSL_verify_mode to SSL_VERIFY_PEER

BBL with report how to get the entire thing to work with the

   Authen::Simple::IMAP
   Net::IMAP::Simple;


Jobst




-- 
When the Pope visits a country he really likes, does he french kiss the ground?????????

  | |0| |   Jobst Schmalenbach, General Manager
  | | |0|   Barrett & Sales Essentials
  |0|0|0|   +61 3 9533 0000, POBox 277, Caulfield South, 3162, Australia

Mime
View raw message