perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Paul B. Henson" <hen...@acm.org>
Subject Re: Apache upgrade 2.2 -> 2.4 and "PerlAuthenHandler Authen::Simple::IMAP"
Date Wed, 20 Feb 2019 02:14:53 GMT
On 2/19/2019 6:02 PM, Jie Gao wrote:
>   
> Found this on CPAN:
> 
> Module  < Authen::Simple::IMAP   (DMARTIN/Authen-Simple-IMAP-0.1.2.tar.gz)

Hmm, perhaps I should have searched CPAN directly rather than relying on 
Google :). Thanks for the pointer…

The last update for this module was in 2009; Apache 2.4 was released in 
2012, so without even looking at the code I am fairly confident the 
module does not support it.

The documentation comment "I've never tried this in mod_perl, so 
including the mod_perl example in the synopsis is pure hubris on my 
part" is also perhaps illuminating :).

Hmm, actually, it looks like the module in need of update is 
Authen::Simple::Apache, not Authen::Simple::IMAP itself. That one was 
last released in April 2012, but does not appear to include Apache 2.4 
support. You could try contacting the author of that module to ask if he 
would be willing to update it?

Or if you are handy at coding, you could try to update it yourself, or 
contract somebody do it for you.

There are a few other authentication modules out there with 2.4 support 
that could serve as examples, including

https://metacpan.org/pod/Apache2::AuthCASpbh

:).

Mime
View raw message