perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Randolf Richardson" <rand...@modperl.pl>
Subject Re: Compile mod_perl 1.0 on ubuntu 12.04 or later
Date Mon, 25 Feb 2019 00:44:12 GMT
> On 2/22/19 10:54 AM, Matthias Schmitt wrote:
> > I doubt that you will be able to compile mod_perl 1.x with newer compilers and operating
systems.
> 
> Hold my beer :).
[sNip]
> I have a Makefile that does all of this.  I suppose I could publish
> it on github or something, but given the age of apache 1.3, it
> seems irresponsible to publish it at this point :).

	Michael:  You deserve to get two beers back for this -- it's 
wonderful that anyone can get help to get older systems working.

	I do agree with you overall though that the focus should be on 
Apache HTTPd 2.4, and given that the older options are discontinued I 
also encourage putting time and effort into upgrading Perl code 
instead of trying to get the older Apache HTTPd 1.x working.

	As long as one isn't relying on the client's dynamic TCP port number 
from $r->connection->remote_addr->port for anything (as I've 
discovered no longer works in the current release of mod_perl2), 
updating to the newest mod_perl2 should ultimately be relatively 
problem-free.  (This client port number business has not been a high 
priority for me to raise as an issue, but if it is something that 
Hans or anyone else is needing I'll gladly chime in with my vote for 
wanting it fixed.)

Randolf Richardson - randolf@inter-corporate.com
Inter-Corporate Computer & Network Services, Inc.
Beautiful British Columbia, Canada
http://www.inter-corporate.com/



Mime
View raw message