perl-modperl mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Schout <msch...@gkg.net>
Subject Re: AuthCookieDBI and Apache 2.4
Date Wed, 20 Feb 2019 16:28:35 GMT
On 2/12/19 1:25 PM, Edward J. Sabol wrote:
> I know AuthCookie has been updated by the magnificient Michael Schout to

Thanks for the kind compliments Ed :).

As for AuthCookieDBI, you may not even need to change it to use
Apache2_4::AuthCookie base, as eventually I managed to get all of the
changes needed to work togehter in Apache2::AuthCookie.  I left
Apache2_4::AuthCookie for historical reasons, and in case further issues
came up that would require more changes that were 2.4 exclusive.

If you aren't doing anything fancy with `require` directives, you likely
don't need to worry about creating an Authz provider, which is where
most of the issues are when moving to 2.4.  Looking at AuthCookieDBI, it
does implement support for `require group`, so if you need that, you
will need to create an Authz provider that implements it.  But if not,
you can probably not worry about it.

Hope this helps.

Regards,
Michael Schout

Mime
View raw message