phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "alex (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (PHOENIX-12) snappy error on osx 64bit
Date Thu, 30 Jan 2014 06:22:08 GMT

     [ https://issues.apache.org/jira/browse/PHOENIX-12?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

alex updated PHOENIX-12:
------------------------

    Summary: snappy error on osx 64bit  (was: snappy error on osx)

> snappy error on osx 64bit
> -------------------------
>
>                 Key: PHOENIX-12
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-12
>             Project: Phoenix
>          Issue Type: Bug
>    Affects Versions: 3.0.0
>         Environment:  OS X 10.9 (Intel Core i5 64bit)
>            Reporter: alex
>            Priority: Minor
>             Fix For: 3.0.0
>
>
> getting this error while trying to do SQL JOIN with phoenix 3.0.0 from OS X 10.9 (Intel
Core i5 64bit):
> org.xerial.snappy.SnappyError: [FAILED_TO_LOAD_NATIVE_LIBRARY] 
> snappy ver: 1.0.3.2
> same code works fine on Linux
> EDIT: seems to be related to a bug in earlier versions of snappy including 1.0.3.2, found
a suggestion here to copy x86_64 (64bit) .jnilib files from snappy distribution directory
/org/xerial/snappy/native/Mac/ to project root path: https://github.com/ptaoussanis/carmine/issues/5
> EDIT : issue is resolved after upgrading from snappy 1.0.3.2 to 1.1.0.1 from https://code.google.com/p/snappy-java/

> this also resolves an issue with SQuirrel GUI client unable to execute SQL JOIN with
phoenix on OSX  with Intel 64 bit processor (throws undescriptive  "state=null" error)
> Pls upgrade the project dependencies to use the latest snappy version



--
This message was sent by Atlassian JIRA
(v6.1.5#6160)

Mime
View raw message