phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Istvan Toth (Jira)" <j...@apache.org>
Subject [jira] [Updated] (PHOENIX-6027) Make Omid testable with HBase built for Hadoop3
Date Mon, 20 Jul 2020 05:51:00 GMT

     [ https://issues.apache.org/jira/browse/PHOENIX-6027?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Istvan Toth updated PHOENIX-6027:
---------------------------------
    Summary: Make Omid testable with HBase built for Hadoop3  (was: Make Omid testable HBase
built for Hadoop3)

> Make Omid testable with HBase built for Hadoop3
> -----------------------------------------------
>
>                 Key: PHOENIX-6027
>                 URL: https://issues.apache.org/jira/browse/PHOENIX-6027
>             Project: Phoenix
>          Issue Type: Improvement
>          Components: omid
>            Reporter: Istvan Toth
>            Assignee: Istvan Toth
>            Priority: Major
>
> Omid tests cannot be run with HBase built for Hadoop3.
> The HBase2 maven artifacts have transitive dependencies on Hadoop2, even when built with
-Dhadoop.profile=3.0.
> This is handled in Phoenix by dependencyManaging every Hadoop dependency, so we don't
hit it there.
> However, we don't do that in Omid, and we run into Hadoop version conflicts when running
the tests (HBase built against Hadoop3, but run against Hadoop2)
> This shouldn't affect the resulting Omid artifacts, as they don't include actual Hbase
or Hadoop code (only dependencies are declared)



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message