phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ankit Singhal (Jira)" <j...@apache.org>
Subject [jira] [Commented] (TEPHRA-304) Remove Support for Java 7
Date Sat, 08 Aug 2020 23:02:00 GMT

    [ https://issues.apache.org/jira/browse/TEPHRA-304?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=17173715#comment-17173715
] 

Ankit Singhal commented on TEPHRA-304:
--------------------------------------

{quote}This change means that the Phoenix 4.x branch cannot move to 0.16 ever, as it is stuck
on Java 7.

Maybe reconsider this, and keep the test workarounds ?
{quote}
Agreed with [~stoty] , due to the dependency on HBase runtime, we can't upgrade JDK for 4.x
branches of Phoenix. Considering Tephra being highly used in Phoenix and benefitted with subsequent
release of Tephra so I also think we should reconsider this. And also it seems that the problem
can be workaround by just adding an option to use TLS-1.2 protocol

> Remove Support for Java 7
> -------------------------
>
>                 Key: TEPHRA-304
>                 URL: https://issues.apache.org/jira/browse/TEPHRA-304
>             Project: Phoenix Tephra
>          Issue Type: Improvement
>            Reporter: Andreas Neumann
>            Assignee: Andreas Neumann
>            Priority: Major
>             Fix For: 0.16.0-incubating
>
>          Time Spent: 40m
>  Remaining Estimate: 0h
>
> Java 7 has long reached the end of its life support, yet Tephra still
> supports and tests with Java 7. After the recent change to use HTTPS, Java
> 7 causes repeated test failures, caused by its lack of support for TLS 1.2 (
> [https://central.sonatype.org/articles/2018/May/04/discontinued-support-for-tlsv11-and-below/])
>  



--
This message was sent by Atlassian Jira
(v8.3.4#803005)

Mime
View raw message