phoenix-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Josh Elser <els...@apache.org>
Subject Re: [DISCUSS] EOL 4.16 and 4.x?
Date Mon, 10 May 2021 15:57:10 GMT
No objections over here! Y'all already know the work Istvan and Richard 
have been doing to push on Phoenix 5.1. That continues to be our focus.

On 5/7/21 11:13 AM, Viraj Jasani wrote:
> Hi,
> 
> Based on HBase community's decision to EOL branch-1 after 1.7.0 release as
> per the discussion thread [1], it is inevitable that we will also have to
> consider EOL of 4.x release line sometime soon.
> 
> As we have discussed in the past, even though Phoenix 4.x should support
> Java 7 only (as it supports HBase 1), we are not strictly following this
> compatibility. With HBase 2 / Phoenix 5, we no longer have to worry about
> this source compatibility. Tephra also continues to support HBase 1 and
> hence should follow Java 7 source compatibility rules and yet I see many
> Java 8 Optional imports in tephra-hbase-compat-2.x modules. Source
> compatibility is just one of the reasons behind HBase community's decision
> to EOL branch-1, many other important reasons are discussed over thread [1].
> Overall, HBase 2 is already widely adopted and deployed in production and
> so should be Phoenix 5 IMHO.
> 
> Given that there are no apparent functional differences b/ 4.16 and 5.1(and
> master) except for maybe few pending forward-ports (if any), I believe it
> is worth considering the ongoing 4.16 patch release as the last one on 4.x
> release line and EOL 4.16 and 4.x.
> Thoughts?
> 
> 1. https://s.apache.org/rs2bk
> 

Mime
View raw message