Yes, restart your cluster 

On Wed, Jun 15, 2016 at 8:17 AM, anupama agarwal <> wrote:

I have created async index with same name. But I am still getting the same error. Should I restart my cluster for changes to reflect?

On Jun 15, 2016 8:38 PM, "Ankit Singhal" <> wrote:
Hi Anupama,

Option 1:-
You can create a ASYNC index so that WAL can be replayed. And once your regions are up , remember to do the flush of data table before dropping the index.

Option 2:-
Create a table in hbase with the same name as index table name by using hbase shell.

Ankit Singhal

On Tue, Jun 14, 2016 at 11:19 PM, anupama agarwal <> wrote:
Hi All,

I have hit this error in phoenix, Phoenix-2915. It could be possible , that there are some index writes in WAL which are not replayed and the index is dropped.

And, now the table is not there, these writes cannot be replayed which result in data table regions also to not come up. My data region is in FAILED_TO_OPEN state. I have tried recreating the index, and still region is not able to come up. I realise that this has been fixed in new version of phoenix, but I am currently on phoenix 4.6 and Hbase 1.0. Can you please suggest a solution?