pivot-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Brown <gkbr...@mac.com>
Subject Re: Change "name" to "label" in container attribute classes?
Date Tue, 28 Jul 2009 02:58:02 GMT
In some contexts, I think "caption" may be a good term (certainly  
better than "name"). Here, though, I think "label" is more accurate.  
To me, "caption" carries a different connotation, like you are  
describing a figure in a document.

G


On Jul 27, 2009, at 9:36 PM, Niclas Hedhman wrote:

> I actually like "caption" even better than "label".
>
> -- Niclas
>
> On Jul 27, 2009 11:54 PM, "Greg Brown" <gkbrown@mac.com> wrote:
>
> Does anyone have any objection to my changing "name" to "label" in the
> attribute classes for Form, TabPane, and Accordion? e.g. instead of:
>
> <TabPane>
>   <tabs>
>       <PushButton TabPane.name="Foo"/>
>   </tabs>
> </TabPane>
>
> we'd have:
>
> <TabPane>
>   <tabs>
>       <PushButton TabPane.label="Foo"/>
>   </tabs>
> </TabPane>
>
> We're using "name" elsewhere to mean "ID" (generally for programmatic,
> rather than human, consumption), and "label" seems more accurate. I  
> think I
> originally used "name" to avoid confusion with the Label class, but,  
> at this
> point, that seems misguided.
>
> Thoughts?
>
> Greg


Mime
View raw message