pivot-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Niclas Hedhman <nic...@hedhman.org>
Subject Re: Change "name" to "label" in container attribute classes?
Date Tue, 28 Jul 2009 01:36:06 GMT
I actually like "caption" even better than "label".

-- Niclas

On Jul 27, 2009 11:54 PM, "Greg Brown" <gkbrown@mac.com> wrote:

Does anyone have any objection to my changing "name" to "label" in the
attribute classes for Form, TabPane, and Accordion? e.g. instead of:

       <PushButton TabPane.name="Foo"/>

we'd have:

       <PushButton TabPane.label="Foo"/>

We're using "name" elsewhere to mean "ID" (generally for programmatic,
rather than human, consumption), and "label" seems more accurate. I think I
originally used "name" to avoid confusion with the Label class, but, at this
point, that seems misguided.



  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message